Spell Check Vs Context Menu Created Documents

I’ve for the longest time been having a problem with LibreOffice spell check and auto spell check not working. (By long time, I mean when I was using OpenOffice and LibreOffice didn’t exist yet). I’d check occasionally for a solution to the problem, try all the stuff I found, and once again, nothing would work. I got annoyed with it and went through my usual “google the problem and try everything that comes up” method. This time, however, I randomly tried something unusual.

Usually, when I create a document, It’s by the methodf (background)–> “New”–>“OpenDocument Text”.

This time, however, after trying one of the fix methods that hadn’t worked before, I started the program by going to –>LibreOffice Writer. I typed in a few inaccurate words and was delighted that it squiggly lined them. Overjoyed that I finally had a working office suite; I closed it then went to the file I’d been working on before the upgrade (just went from 3.6 to 4.0) and opened it. To my confusion, nothing was squiggly-lined. I typed something in wrong (on the snowball’s chance in hell I’d spelled everything right on my own.) and still got nothing.

Frustrated, I opened a document via the method again and tested it out again. Squigglies kindly highlighted my bad spelling again…

I then saved that document to my desktop and closed it. Upon double clicking and opening again, the document still had the correction squigglies.

I then went back to my non-correcting document and ctr+c’d everything and closed it. I went back to my self-correcting document and ctrl+v’d into it. Squigglies now present on the copy of one of my real documents. I “save as”'d it and navigated to the location of the original, overwriting its file. I then closed the file and opened it back up. Squigglies still present. (Also, on a side note, it now took about 1 kb less space than before.)

Okay, to cut the summarize my question: Why does Libre(&Open)Office Spell Check not work when a document is created via the right click/context menu? And how do I correct this?

Please have a look at this workaround (“Step 2 for LibreOffice 4.0”)

When I’m starting program it is no language to check spelling.

See also:

Spell checker not working on Docs created from desktop or folder

When I create a new Document from the windows right click new menu there is no dictionary