Spell checker not working in LO version 5.1

In Linux Mint 18.1 I have installed libreoffice-l10n-en-gb, but there is still no highlighting for misspelled words in Writer. In options language settings, locale setting is “Default - English UK”.

“Check for updates” is disabled under my “extension manager”, and there are no extensions listed.

The spell checking is working for a “.doc” file I have but not for a “.odt” file that I have downloaded.

For starters, read this tutorial.

Thanks for the link. Unfortunately it is for Open Office which is a bit different. For example I couldn’t see where you set the language under paragraph / font.

I updated my question.

Language is set on the paragraph style, not on the paragraph format. You can also set it locally on character settings and character styles. So open the style editor, right click on Default Style → Modify and on the Font tab, just below the box with the available fonts you’ll find the “Language” drop down menu. So the guide linked by @gabix is still valid on LibO.

Got it. Thanks.

Gathering from your comment, I conclude that you simply do not have any appropriate spellcheck extension, i. e. for English(UK) or any other language that you might need. Go to the extension page, find and download what you need.

OK, I installed the “English spelling…” extension, there’s still no spell checking.

Did you restart LibO after installing the dictionary?

I update my question.

OK, now, when you have installed some extension, did you walk through the tutorial again?