Spellcheck doesn't recognise words - all the words underlined in red


I recently updated from Ubuntu 10 to 11.10, now installed Libre Office 3.4.4, and running all this on my Lenovo X201 in Gnome Classic. Since the update I have an issue with the spell-check in LO writer.

All the words, even very simple ones, are underlined in red wavy line, no matter which of the installed languages I say the text is in. I already removed LO (originally had a 3.3 version), re-installed it (3.4.4). I removed and re-installed all my spell-check-extensions in the extension manager. I went through my language settings in the preferences. Alas, to no avail… I currently have English, French and Dutch dictionary extensions installed.

The strange thing is that as I’m writing this in Firefox, the spell-check does work. But I don’t know whether that’s the same one…

I have one other issue with ‘loading BASIC of document’ - but will make another post for that.

Any help very welcome.


Quite often, there are issues with the user profile when upgrading to a newer version. In most cases, it simply helps to reset the user profile.

If it doesn’t help. check Menu “Tools” → “Options” → “Language Settings” → “Writing Aids”. Which “Language Modules” and which “User-defined Dictionaries” are available there?

Wow thanks a lot tohuwawohu!

Your first option, to reset the user profile, on first sight solved all my problems all at once. Thanks for helping out, great to have Office up and running as it should!