Spelling keeps using Dutch even if the style shows English in the font

I’m writing a book in libreoffice writer and struggling massively to change spelling to English. I have a style ‘book1’ and it has in the font area ‘English’ as language. But the spelling keeps using Dutch.
When I change to another style ‘Default’ which has ‘English’ as well as language, then sometimes all ‘spelling errors’ dissapear … but sometimes they just don’t dissapear and if I check the words which are wrong it shows options in English, eventhough the style is Default. This drives me completely crazy.

what I want to do is reset the complete document in Dutch …

any advise is welcome.


Your description is confusing. You start with something that makes an impression that your goal is to have your text in English, but you don’t know why, it turns Dutch:

Then you write that you want Dutch:

… Anyway, you didn’t mention your LibreOffice version as reported in Help|About; and if you copied the full data from there, it would also show what OS you are using.

If you use Windows, and if your OS input language is Dutch (typically bound in the keyboard layout), then it’s normal that by default, the text that you type gets the language detected from the system input language. This feature is controlled by Options|Language Settings|Languages, [ ] Ignore system input language allows you to disable this feature. But I’d suggest you to not do that; creating styles for each language is IMO wrong (you would need a complete set of styles per each language). Text language is IMO one of those cases where use of direct formatting is fine. Just using different input languages set up in your system, and using the respective OS keyboard shortcut to change the language as soon as you switch from English to Dutch, would soon inscribe the process into the muscle memory, and become easy and convenient.

Of course, all that is only relevant if I guessed your OS correctly :wink:

Hi Mike … thanks for your fast reaction and yes, you are right, my message might be confusing because i’m confused myself.
It seems as I understand, that I cannot change the spelling control language of libre office write ?
I used to work with word, and there you could just determine the language of a texte independantly from the language of your ‘system’ …
So I don’t understand the relevance of your explanation.
I have an issue that most of the text i’m writing in English (almost all words) are now red underlined as spelling mistakes (logically because it uses Dutch) … but even when those text fragments are made in a style where in the ‘font’ section of the style, English is selected as language, then still it shows spelling errors and suggestions of change in Dutch ???

When I select a paragraph, it’s also impossible to determine it as an English texte …
I’m blocked … and don’t see an escape …

thanks for your suggestions,


You misunderstood.

Well, …
You can apply whatever language you want to whatever part of the document, just selecting the part and setting its language in the character properties (Format|Character), or using Tools|Language. This makes the selected part to have the wanted language applied directly.

You may also define the default language in a style: that language will be used when the language has not been applied directly to the text using that style.

When you type, and your OS tells LibreOffice that user uses Dutch, LibreOffice applies the language directly - so the style setting is not relevant (but you may override the setting manually as explained above).

Or you may disable the feature that LibreOffice takes care about OS - and there my explanation above is relevant (I assumed that you know about input language of your OS, and such).

Anyway: does selecting the text, and setting the required language using Format|Character (on the dialog’s Font tab) help? If it doesn’t, we have some different issue. If it helps, it makes sense to continue looking how relevant my explanation is :slight_smile:

1 Like

Hi Mike,
thanks that works … I have selected the complete texte and with ‘charactor’ changed the language which was ‘dutch’ … to English …
So that solves this rather frustrating problem.

Have a nice weekend,