Stable crash on KDE + AMD graphic

LibreOffice goes out from screen and disappears from the taskbar in 0.5 - 4 minutes after the start.

Crash occurs on both Wayland and X11. The office works less on Wayland (1 min), and on X11 longer (~4 min). The error is reproduced for me if the LibreOffice window, expanded to the full screen, is overlap by the Firefox window.

What I tried on X11 :

1 Disabled anti-aliasing in normal libreoffice mode (Tools-Options-LibreOffice-View)
2 Disabled full hardware acceleration in LibreOffice safe mode
3 Reset the user profile, so that LibreOffice booted as for the first time
4 Reinstalled LibreOffice
5 Reinstall libreoffice-kf5 package over rpm-ostree

All these measures did not help.

I tested on the same machine with AMD graphics LibreOffice on GNOME - it works stable.

I tested LibreOffice on KDE on old machine with Intel graphics without libreoffice-kf5 - it works stable.

I would be very grateful for any thoughts, that would help solve the problem.


The failure might be due to that, try to deinstall the package. You will lose some KDE integration, but it might actually work then.

Thank you very much for your ansver. This is really important to me, because problems with the office greatly reduce my efficiency.

I’ve done this before.

Starting in safe mode, disabling hardware acceleration, resetting the profile, disabling the use of Java was before I installed libreoffice-kf5.

His installation did not change the situation in any way.

I took a picture of the window that appears when the office is first started.

It didn’t seem to appear on the first machine where the office worked well.

I Googled, but unfortunately I couldn’t find what it means. Can the further work of the office be related to how I answer the question?

Can’t access the Google drive link you provided.

If it is only a screenshot, attach it to your comment with the upload tool (looking like an upward arrow from a paper tray).

Please do not use the Answer or Suggest a solution field for comments that are not an answer to the original question / solution to the problem, use Comment instead. Thanks.

I ask me to excuse, I wrote from the phone and I did not have a complete picture of the tape there. I tried to fix her.

I googled yet, but did not find what the background mode is for LibreOffice. I use it for a long time and it helps me a lot, but this I see the first time

when I tried to download the picture yesterday from my phone, I had a limit on the size of the uploadable picture - 4 KB

As far as I understand, you already have a LO occurrence running in the background. I don’t remember if LibreOffice has OS-property “single execution” (approximate wording !). If this is the case, only one occurrence is allowed and since your active occurrence is in the background, you can’t interact with it apart from using command line.

Try rebooting; this will terminate all processes. Is LO still in the background after reboot?

You can tell with command (in a console) ps x|grep soffice. If you get something like /usr/lib…/soffice.bin …, it is executing. You’ll have to find what is launching it on boot.

Meanwhile, you can press Force quit to get rid of the background occurrence.

Shut down all instances of LO (killall soffice.bin) and then start it like this:

SAL_USE_VCLPLUGIN=gen /opt/libreoffice7.2/program/soffice

It should start with a stable, generic Windows 95 style. No bullshit, no crash, all GUI elements working as expected. If you like this rock solid mode, you may add this line to the soffice starter script:


Hi, ajlittoz !

This message did not appear after the reboot.

It appeared only at the first start of the LibreOffice.

I can’t guarantee a causal relationship, but what I saw:

  1. I have installed a new system, have installed the LibreOffice through a Flatpack and when this dialog appeared, pressed the “Force Quit” . After that, the LibreOffice arbitrarily stopped working after the start - this is detailed in the first post above.

  2. I have new installed the same system new, have the same installed LibreOffice and in dialog have pressed “Allow” - until he do not show such behavior with an arbitrary stop.

I will compare on my two machines (where the LibreOffice works well and where there were failures) the background processes of LibreOffice.

Thanks !

Hi, Villeroy !

Thank you very much for your answer.

I will definitely try to apply your solution to the Flatpack installation of LibreOffice.

Thanks !

You didn’t mention in your first post the name of your Linux distro.

I guess you manually installed LibreOffice (clue: FlatPack package) instead of doing so through the distro package manager (two main brands: dnf and apt; there are others depending on the distro). I highly recommend you install any software with the distro native package manager. Proceed with manual install only when the application is not packaged in the distro. Configuration may differ a lot (e.g. location of library or auxiliary files).