Stop autocorrect of hyperlink insertion

How do I eliminate hyperlink insertions within cells when it sees the use of “@” in a piece of text?
Listing the cell as a text entry is ignored and the inserted text highlighted and made a hyperlink when the text does NOT have that purpose

Hi - Uncheck Tools > AutoCorrect Options > Options tab: URL Recognition