Stuck on form-based filters

What have I not understood?

I have a number of forms which access different tables. In the form navigation toolbar there is a form-based filter icon. When I click on this, as expected, a filter navigator window opens and the fields on the form go blank. I can enter a value in a field and, if I move on (TAB or RETURN), the filter value appears in the filter navigator window.

How do I then apply the filter? The form navigator toolbar disappeared when I clicked on the form-based filter icon, and no other toolbar has appeared. If I manually re-open the form navigator toolbar, all buttons are greyed out and non-functional, so I can discover no way to apply the filter and return to my tables. This behaviour seems to apply equally to my various different forms.

Help, please!


On Ubuntu 20.04 with LO v7.1.1.2 when starting the form-based filter there are there icons in the lower left of the form:

image description

From left to right, Apply Form-Based Filter, Filter Navigation and Close. The first and last brings back the Navigation toolbar while the center toggles the filter box.

If you do not see these icons it may be because the window has hidden them (you never stated your OS or LO version). Just re-sizing the window should display them.

Hmm … This is on Mac OS 10.13.6 with LO v6.4.3.2. Resizing the window did not reveal anything. I see LO v7.0.4 is now available and shall install that as an obvious option before commenting further.

If you continue to have a problem, you may want to try resetting the user profile. See-> LibreOffice user profile. And if that doesn’t work, probably a bug. Report that here → Bugzilla

Thank you. Updating did not make any difference, but running in safe mode did. Not sure what to do next, I guessed that the problem might be with one of my own macros, so commented out all uses of the macro “HideAllMenuToolBars” in case this was concealing the form-filtering toolbar. No change - but then, when trying to investigate toolbars again I hit View|Toolbars|Reset … Magic! The relevant toolbar (never seen before) appeared and this now seems to work regardless of the restored macro “HideAllMenuToolbars” (so that was not the problem).

A little mystified, but I guess this has reset something in the user profile.