Styles don't work on Japanese characters.

I’m writing a document that uses some Japanese characters. It’s intended to be read from a distance, so I’m using custom styles with rather large font sizes. But, when I type Japanese characters, they don’t respect the font, size, etc. from the style. Every such character is printed in a font called “NSimSun” and size 10.5 points. How do I make styles work on Asian characters?

I know the font I have selected would work, because it does just fine when I use direct formatting.

It’s LibreOffice Writer ver, running on Fedora Linux, if that makes a difference.

I’ve attached a screenshot to illustrate the point. (Note that “用いる” is Japanese for “uses”.)

Do you set the font size for western characters, or for Asian characters?

Note that you need Asian checked under OptionsLanguage SettingsLanguages.

I see, I didn’t have “Asian” checked under Languages, so it didn’t give the the option for Asian Text Font. Thanks for your help!

What if you change the language in Asian Text Font to Japanese?
NSimSun is Chinese fonts. It is better to change to Noto Serif CJK JP (OTC/.ttc).

Do not answer a question unless you provide a real answer.

Since the asker does not complain about missing characters or similar issues, and the screenshot demonstrates that the font can show the required size when manual formatting is applied, I would assume that the NSimSun font has a sufficient CJK coverage and changing it to another font won’t solve the problem.

And thanks for the pointer! The font looks fine for CJK.