Sudden Problems With Sorting A List

In attempting to Data|Sort a range (R13C26:R45C35)
My cursor is in R13 C26 (or Z). I highlight A range of 10 columns, and 32 rows,
It predicts sorting by row 13, instead of by the data in column Z. This is wrong.

If I draw the range deeper (say 5 more rows), It will predict sorting by data in column 26 (Z), which is the correct sort order. But when it sorts, it crashes, every time.

This just started today. I have tried shut down, reboot etc. I converted from Open Office recently, but have never had a problem like this.

Yesterday, a named range did disappear in a spreadsheet I use daily.

I have Libre set for R1C1, but it only gives me alphabetical column names in the sort choices, and I think in some other places. (I see column 26 on the screen, but Libre calls it column Z. However the R1C1 format shows in the formulas.

Help? Thanks.

I run Windows 7 Libre Office

Please try resetting the user profile, sometimes solves strange issues.
Usually it’s enough renaming/deleting the file “user/registrymodifications.xcu”, it affects all the options in Menu/Tools/Options, and the files “user/basic/dialog.xlc” and “scrip.xlc” are overwritten, additionally custom colors in “user/config/standard.soc” are lost.