Suddenly, I cannot open docx or xlsx files from windows 10 file explorer but I can open doc files

Brand new Windows 10 desktop with LibreOffice installed. I successfully set LibreOffice as the program to open my old WORD and EXCEL files, and was able to open them from the File Explorer screen for a while. Then all of a sudden the docx and xlsx files wouldn’t open and the little “spinner” displays forever. If I click on anything else once I reach that state, a “not responding” message displays at the top left of the screen. If I click on the red X close button in the upper right, file explorer closes. I CAN open older doc and xls files from File Explorer. My CPU utilization does not spike when the docx or xlsx files are hung up. I CAN open docx and xlsx files if I click on the LibreOffice shortcut and display the files from there, but I find it easier to do from File Explorer. I’ve never run LibreOffice before, so I’m trying to figure it out as I go. Originally I thought the problem was in the Windows 10 File Explorer, but someone suggested it was a LibreOffice problem. I purchased this my new HP desktop from Staples and they installed LibreOffice as part of their initial setup/configuration of the desktop on Sept.6, 2018. The shortcut says it is LibreOffice 6.1. As I said, File Explorer opened my files with LO Writer and LO Calc for a couple of weeks, and the a few days ago it just stopped working.

Here’s how to restore the file association to LibreOffice:

[EDIT_1:] Try to reassign non-funsion file types. Select LibreOffice as a program (not save mode).

[EDIT_2:] With save-mode I just wanted to suggest that there are two possibilities. So it should be selected in the process described in the link, the correct symbol.

As I said, I successfully set the LibreOffice programs as the default program to use to open doc, docx, xls, and xlsx files. The association hasn’t been lost, as far as I can tell. I’ve checked the default apps by file type in Settings, and it shows LibreOffice Writer as the default for all doc_ filetypes, and LibreOffice Calc as the default for all xls_ filetypes. But docx and xlsx files are no longer successfully opening when I double click on them in Windows 10 File Manager.

Try to reassign non-funsion file types. Select LibreOffice as a program (not save mode).

I don’t understand what you mean by that. What are the funsion file types, and how do I select LibreOffice as a “program”, rather than “save mode”.

Okay, this is weird: I just found that I was able to open both docx and xlsx files with LibreOffice by double clicking the file in File Manager. Yesterday, I just got a “not responding” message when I did that. HOWEVER, as soon as the file opens, File Manager displays the “not responding” message and all I can do is close file manager and then open it again if I want to open a different or additional file. When I close an opened file, File Manager is still hung up. I did not make any changes.

See [EDIT_2:] in my answer.

When I right click on a docx or xlsx file in File Manager, File Manager hangs up. It does not open the menu allowing me to choose a program with which to open the file. Also, I wrote a couple of days ago that I WAS able to open files from File Manager, but that the act of opening them left File Manager “not responding”. I’ve discovered that double-clicking in File Manager to open a file ONLY works until the file has been SAVEd in LibreOffice. (see remainder of comment below)

Once a docx or xlsx file has been SAVEd from LibreOffice (and it prompts me to click on a button specifically to save in the “Excel 2007-2019 Format” instead of using the “ODF Format”) it can no longer be opened through File Manager…only through LibreOffice. I realize, now, that the problem exists only in files that I have edited and saved in LibreOffice. However, the problem did not occur until a few weeks after I started using this new desktop computer.

I’ve tested and found that double clicking or right clicking a file in File Manager AFTER that file has been saved in docx or xlsx format in LibreOffice, cannot be double clicked or right clicked to open in File Manger, EVEN if the file has subsequently been saved in doc or xls format. Even though doc and xls formats use more disk space, I thought I would revert to that format for frequently opened files. But that does not resolve the problem.

I’ve also found that after xlsx and docx files have been saved as xls or doc, or even ODF, the file extension still displays as xlsx or doc in File Manager, and also in LibreOffice file lists or when the file is opened in LibreOffice. Once the file format is changed, the files can be double clicked or right click opened in File Manager, but File Manager hangs up and says “not responding” after that. You have to close File Manager to open another file.

Same issue here. I guess that Windows 10/MS Office/the registry could be responsible. There had been an Office suite installed on my new laptop, which I have uninstalled. .docx is associated to LibreOffice, but still, when I put the mouse over a .docx file, the popup says “Microsoft Word Document”. Right clicking a .docx file doesn’t open the context menu but freezes the Windows explorer. I repeatedly uninstalled Office using the o15-ctrremove.diagcab tool from Microsoft, but in the Default Apps menu, Windows still allows me to select MS Word and Excel.

I searched the registry and found several instances where .docx seems to be associated with Word/Office. But I don’t really understand the registry and I don’t want to break anything by editing there.

Solution found!: I have no idea why this works, and I have to credit this poster on this site:

but it turns out that setting Windows File Explorer to the PREVIEW PANE instead of the DETAILS PANE (that is accomplished under the VIEW tab at the top of the File Explorer page) resolves all the problems with single-clicking, double-clicking, right-clicking docx and xslx in File Explorer…apparently, regardless of WHICH “office” programyou are running.

Simple and also easily Done! When you right click on a Libre Doc → select the → OPEN WITH option in the menu - when that list of Defaults opens → Select → “Choose another Program” → find the Libre doc ICON in that list and highlight it then -->> Place a Check in the BOX says always open with (Libre) at the bottom of that Open With >“Choose” List →
close out and you will see’ that all the icons on all your Libre Doc have changed back to the default “Libra Doc” Icons - or whatever Default Program you selected as applicable to -->>OPEN WITH – that fixed My Issues Cheers Dasha