Table of Content numbering level 2 space missing?

cf. the image: there is a “. and a space” behind the first level e.g. “1. Welcome”.
Why is that not in level 2? There there is no “. and a space”, causing the number to stick to the word.
I opened the Paragraph Style window to see if I could find out the difference between level 1 and 2, but couldnt.
When I go to the text, there in a heading level 2, there is a “. and a space”. It’s just not taken over in the TOC formatting.

Anybody? Thy

You have to configure that yourself in the TOC dialog box, second tab. In the marked box you can enter any separator text like a space to keep the number and entry apart. Play with those settings, it’s easier to learn to get the most out of them by experimenting than by reading about it.