Table of content page number offset

I skipped numbering the title page by setting an offset in the page number field,
but the table of content do consider my offset.
How can I match the table of content page number with the displayed page number?

I’m not sure if I got your issue correctly. I suggest not using an offset for page numbering. Instead, use the correct numbering and convert the first page as title page via Format → Title Page.

If you want to use different numbering styles or reset the numbers, you should use page styles instead. Have a look at two similar answers of mine:

Thank you! Your solution is definetevely the right one. I set my first page as title page with Format > Title Page. Then all the following pages are marked correctly. However I’m using roman digits for the following two pages and then the regular numeration for the other (by reseting with Insert>Manual break and changing Page Style). My table of contents display it correctly but all in the same “style”. For instance: 2,3,1,2,3,… instead of ii,iii,1,2,3, … What would you suggest?

That’s fairly easy if you are using separate page styles (as suggested).

Go to “styles and formatting” (F11), choose 4th tab “page” styles and modify the desired page style. On “page”-tab find “layout settings” and choose the format, in your case “I, II, III, …”. Press OK and update your table of contents.

If desired, I can also update my provided example.

Awesome! Thanks!