Table of Contents Dot Leaders Spaced Unevenly

I want to create a table of contents. I want to use dot leaders between the chapter headings and the page numbers. This I can do. However, the dots are spaced unevenly (grouped into pairs instead of constantly spaced). This is most obvious when exported to PDF and zoomed in:

Even at a normal zoom, the effect is sufficient to be very unattractive. How might I avoid this?

To add to OP’s answer, this is indeed a “bug” (or, at least, an unexpected feature!) of Linux Libertine. Using the ordinary “full stop” (period) produces the stuttering leader behaviour.

It looks to me as if the “auto” dot-leader in LibO is picking up Linux Libertine’s triple-dot leader which doesn’t get spacing on right or left, thus the “pairs” with one in the middle (if you look closely!).

As illustrated above, it is still possible to use Linux Libertine and get well spaced leaders, but it takes selecting a different leader character. Go to the Format > Paragraph > Tab > Character menu, and use the U+2024 single dot leader character = ․ (available from Insert > Special Character... choose the “General Punctuation” range):

And the character selection:

Fabulous! Thanks for this comprehensive response.

Right click the ToC, select Edit. Go to the Styles tab, select the paragraph style being used and click Modify. Go to the Tabs tab and select the desired leader. I have LO 5.1.3 and do not have this problem.

Thanks for the suggestion. I’m running 5.1 and the Tabs settings in the paragraph style are already correctly set up. The problem persists.

It was silly of me not to check this factor sooner, but the problem was with the font (Linux Libertine), not the program. Other fonts behave as you would expect.