Table of contents in Writer is broken

Hey guys,
I’m having some problems with the table of contents. When I create it, it puts just one item on its individual page and leaves the rest of the page blank, so if I have 10 headings in my document, the table of contents is 10 pages long. How do I fix this? Thanks in advance!

It is most likely due to a spacing or “insert page break” setting for the content style. Could also be a setting in the ToC or a page style, or something I can’t think of.

Impossible to determine exact cause without access to the document.

@Drobdien, keme is correct, the style you are using for your TOC contents is inserting page break. Have you been overriding styles in your document, instead of using a template approach? If so, bad idea, overriding styles is a slippery slope…have fun.