Table primary key AutoValue problem (can not be auto-incremented)

Hi there! I came across this strange problem and am puzzled. Namely I made a table, set the primary key as auto-incremented. But when I went to enter some data to the table, the primary key can not be auto-incremented. When I hit Save button, I get an error, vid the attached pic. Where did I make mistake? How can I solve this problem? I know I can delete this table and make a new one. THANKS ALOT!!!


Please do not make people dig through your old posts just to find out what specific LO version,OS and database you are using. Please include with each posting.

LO 7.1.5, Mac OS, dateabse HSQLDB.


I have no problem with this. Your screenshot does not show AutoField in the ID column. Something is not processed correctly. My test before saving:

Screenshot at 2021-09-14 09-29-56

and after saving:

Screenshot at 2021-09-14 09-30-22

Can you post a sample?

Really sorry but I just copy paste (only structure, the copy works well) and deleted that problematic table. :frowning: Yes I noticed that there is no Auto Field written at the 1st column which was very weird. My other tables all showed Auto Field as sees in your pic.

Does this mean your problem is solved? Not clear from what you just posted.

Yes, the problem is solved. :pray: