Template not visible

I recently created a new Writer template by modifying and saving an existing (custom) template. Both the old and new versions are located in a template directory which I created myself and set as default.

I have no problem creating a new document using the older templates, but the newest one isn’t visible. I have tried exiting and reloading the program to ‘refresh’ the directory with no effect. I also tried templates → manage → import on the File menu, which worked once but did not ‘remember’ the new template the next time I started the program. Same with the import button in the Template Manager.

How can I get the program to ‘see’ all the files in my default template directory automatically?

I am using LibreOffice under Win8.1

Do you only have one location defined for templates, as indicated in this answer? Also make sure you have the correct tab (file type) selected in the Template Manager.

I’m not sure I understand the first part of your answer. If I look at paths under options, there is only one path for Templates: D:\MyFiles\Documents\Templates. This is a folder I created and set as the default template folder.

On your second point: if you mean, documents vs spreadsheets vs presentations etc. then yes, I am looking at the right one.

As I said, the (document) templates I created earlier show up fine. It’s only the latest one that doesn’t. All are located in the same folder.

@avoran, thanks for clarifying. Those were the first two things that came to mind. It sounds like you have a separate issue and my answer does not apply.