Templates not loading or saving to Computers on Google Drive

LibreOffice -
MacOS - 12.5.1

I have my iMac synced with Google Drive which creates a section called Computers on Google Drive. My MacBook is also synced to Google Drive. So, in the Computers section of Google Drive I have both computers which are then accessible to each other.

I have my LibreOffice templates located on the iMac in the Computers section of Google Drive. And I have that location designated in the Preferences - Paths in LibreOffice as follows - /Users/xxxxxxx/Library/CloudStorage/GoogleDrive-xxxxxxx@gmail.com/Other computers/My iMac/Templates/LibreOffice.

The problem I’m experiencing is that my default template in Writer won’t load. Nor can I access any of my templates in the template manager. Nor can I save a new template.

I have Preferences - Paths - My Documents set to a similar location on Google Drive and everything works fine. It’s just the templates that aren’t working properly. I can, however, access the templates via File - Open.

Any idea why the default template won’t load, or why I can’t access them in the template manager, or why I can’t save a new template?

If you simply stored your template on Google Drive as you would for any ordinary file (drag’n’drop on the GDrive icon, using command line, …), this is no surprise.

Templates must somehow be “declared” to Writer before they can be accessed as templates. This is done with File>Templates>Manage Templates where you “import” the template names into your user profile “dictionary”.

If this doesn’t fix the issue, provide more details about your procedure to store the templates and what you did in Writer.

1 Like

Whenever I attempt to import a template from the template manager, I get the following error message -

Error importing the following templates to My Template: file:////Users/xxxxxxx/Library/CloudStorage/GoogleDrive-xxxxxxx@gmail.com/Other computers/My iMac/Templates/LibreOffice/JST - Writer Template1.ott

Problem solved. I needed to create a location for My Templates on my MacBook. Once I created a folder on my MacBook and added that folder to Preferences - Paths - Templates (in addition to the Google Drive location), everything imported automatically and everything works fine.

Thanks ajlittoz, for getting me thinking about needing to “declare” in Writer.

1 Like