Text Alignment


I’m trying to write in Arabic but when I type, the text is not aligned to the right as it should be, especially for the punctuations. Do you know how?

What is your LibreOffice version? On which operating system you are using it? What product do you use (Writer)? What is the file type (ODF?) you are trying to use?

Hi @Abdullah1,

I’m not sure what’s going wrong here, but we’ll try to help you out. Please file a bug about this problem, and provide a list of steps that can reproduce it. The QA team will be happy to help you track down this issue!

Please post a link to any bugs you file in a comment below using the format “fdo#123456”.


Maybe helpful:

→ TDF Wiki – RTL Bugs

(see also:RTL status for Libre Office 4.0.0).

I am not an expert, but file type format should not effect the RTL. But you are right there were several RTL fixes in LibreOffice 4.0, so first of I would start to solve this problem by installing LibreOffice v4.0 from https://www.libreoffice.org/download

@Abdullah1 – If none of these bug reports seems to apply to your problem, and if installing LO 4.0 as @froz suggests doesn’t help, please feel free to file another bug.

@Abdullah1,- Possible workaround is to format your page style / default with alignment to the right and save this file as your “ArabicTemplate”.

As Arabic is a CTL language, you also can have a look in tools / options … to see if you can introduce an standard alignment for Arabic Right-to-Left.