'Text Box' in Draw not working


I started a new document in Draw, by drawing 2 arrows. Then I wanted to label them, so I did the following (explained in Adding Text ):

"Adding a Text Box

Click the Text icon Icon and move the mouse pointer to where you want to enter the text box.

Drag a text box to the size you want in your document.

Type or paste your text into the text box.

Double-click the text to edit it or to format text properties, such as font size or font color. Click the border of the text box to edit the object properties, such as border color or arranging in front or behind other objects."

But it was NOT possible to write anything in the box. Neither just after ‘dragging’ it, nor after one mouse click or a double click!
What is going on?

I can add that I use this Libreoffice:

Build ID: 1:6.0.7-0ubuntu0.18.04.9
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Locale: da-DK (en_US.UTF-8); Calc: group

On Ubuntu 18.04.3 LTS.

GNOME: 3.28.2

On Lenovo ThinkPad L570.

(The reason I haven’t upgraded is because Ubuntu wouldn’t…)

I look forward to any help with this very strange behaviour.


The simplest way to label an arrow is to associate text with it so that text follows when you move the arrow.

  • double-click on the arrow, a text blinking cursor appears
  • type your label
  • optionally, select your text and modify its attributes (font face, size, color, …)
  • click anywhere, the text is now on thearrow

Since the text is exactly on the arrow, this may not be legible, nor fit your needs.

  • click one the arrow to select it
  • Format>Text, Text tab will allow you to change text position relative to arrrow
  • change the anchor first, then play with spacing
  • experiment because I’ve not discovered yet the exact effect of the changes (i.e. I can’t predict precisely where text will go from the numbers alone)

To edit an existing text, double-click on the arrow then select text or portion of with the mouse.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!


There is only one text attached to any object. Therefore, you can’t have both a start and end label on the same arrow.

There is however a workaround:

  • create a text box for the start label, format the way you like
  • create another text box for the end label
  • instead of using an arrow, select a connector (straight connector end with arrow is the closest equivalence to a standard arrow
  • when you hover over the start label, connecting points appear on text frame; press the mouse button on one of them and without releasing drag to one connecting point of the end label; release mouse button

If you’re not satisfied with your connection, select the connector with one click then drag one end to another connecting point

Now to change position of the “arrow”, you must drag the labels (which have become primary objects, the connector is just an auxiliary secondary object, well just a slave connector between the labels). To disconnect, drag the a connector end to a position where there is no object.

OK. I can move the label to the end of the arrow. But I can’t see how to rotate it 90 degrees. And I need a label at each end of the arrow…

It seems more logical and easy to me, if someone ‘repairs’ the Text Box function… Why doesn’t it work on my machine? In your “EDIT 1” you say “create a text box”, but that is exactly what I haven’t been able to do… Catch 22…

To create a text box, select the text box tool in the upper tool bar. Drag a rectangle with the mouse. When you release the mouse button a rectangle is highlighted with a blinking cursor inside.

Did you forget to drag to define the box extent?

You are asking me to do exactly what I have already done, AND told you that I have done… It still doesn’t work.

Very strange! I’m now short on ideas. That a function which always worked in the past and still works in 6.2.x. What happens exactly when you release the louse button? Do you some transient blinking rectangle or something else?

I am “kind of” glad to hear that it is supposed to work… :wink:
There doesn’t seem to be a way of uploading an image here, but I have put the screen shot here:

It was taken just after releasing the mouse button. That’s when I type but nothing happens…
Is it a matter of restarting Ubuntu or reinstalling LibreOffice - like in MS-Windows…

I may have a clue. From the shot, the box looks like it is selected (i.e. not in text entry mode). I simulated that and if I try to click where the blinking cursor should be to switch to text entry, everything disappears.

To prevent that from happening, I hover my mouse over the frame boundary. The mouse cursor becomes a hand cursor. If I double-click, I get now the blinking insertion inside the box.

Does it work for you? If it does, the question is: why isn’t it activated from start instead of going into box positioning mode?

I have found a solution. The error is in this part of the instructions:

“Drag a text box to the size you want in your document.”

If I just click somewhere, I get a text box and can start typing.

I also just discovered that there are 2 icons! One with the caption “Text Box” the other with the caption “Insert Text Box (F2)”. THAT’S confusing!

Now - how can I change font size??

(This is a strange program!)

It has not received as much maintenance and evolution support as the other components.

Changing text attributes is a bit more complicated than in Writer or Calc. Styles are less developed and probably less well-defined.

If you succeed identifying the style used when creating a text box, modify it.

Otherwise, type your text first. Then select portions of it and change the attributes.

Eventually, explore the style feature to see if you can have a more user-friendly functionality.

OK. I found “Manage Styles” in the Format-menu. That solved that. :slight_smile:

Short solution:

The error is in this part of the instructions:

“Drag a text box to the size you want in your document.”

If I just click somewhere, I get a text box and can start typing.

Details: See the dialogue in the comments to the other answer…