The connection could not be established. The database was created by a newer version of LibreOffice

On Saturday I created a database in Base. Spent about three hours work on it. On Sunday tried to open a table and got the following errors:

The connection to the data source "xxxxx" could not be established.
SQL Status: HY000
The connection could not be established. The database was created by a newer version of LibreOffice.

No updates involved. I get the same error if trying to open a query.

My environment:

  • Linux Mint 17.3
  • LibreOffice
  • Database is registered with LibreOffice
  • java version “1.7.0_151”

I have found a couple of similar questions here and here neither of which have an answer.

I also found this question but it seems more related to opening OpenOffice files.

My main question then, is how can I access the database?

Also, can I retrieve the data in any way?

And finally, how can I create a database on one day, and have it inaccessible the next?

Let me know if you neede any more information.Writers Books.odb

Have you modified path settings for HSQLDB? Your last link is NOT related to just OpenOffice files. It is just one of many ways to screw up an Embedded DB.

No, I haven’t modified anything. The settings should be just as they were since I installed Linux Mint, unless some other program changed them. How do I check?


My first thought, since you successfully created the DB, was that a path was added to point to a different HSQLDB jar file. This is done from the menu Tools->Options then under LibreOffice->Advanced. Once there select the Class Path button. It shouldn’t contain anything.

Your actual error message is indicative of a missing Java installation. On the same page as above (before Class Path button), make sure Use a Java runtime environment is selected and in the pane below one of the JRE’s (can have multiple) selected.

image description

I also noticed you are using a somewhat older version of LibreOffice. You probably should upgrade as v5.4.x is most recent. Along with that Java is also old & upgrading to v1.8.x or better would be best.

Edit 11/07/2017:

Had a few minutes so I created a working .odb:

Writers Books.odb

If this answers your question please click on the :heavy_check_mark: (upper left area of answer).

Thanks for this. Unfortunately everything is as it should be, apart from the versions of LibreOffice and Java. One thing that I’ve found is that the HSQLDB installed package is libhsqldb1.8.0-java, although version 2.2.9 is available. Should I upgrade this, or will dependency madness lie there? (I’m reluctant to download and install manually because of the advice here)

If you want, and your DB contains no personal or confidential info, post a copy in your original question. Have given you enough Karma to allow this. Then I can see if I can open or exactly what the problem may be.

Don’t touch any of the installed files. If you ever want to use a newer HSQLDB or even another external DB there are ways to do that. I currently have about half a dozen different DB’s - mostly for testing.

Also, can you create a new Base file now , close it and then open it again? Another point. It’s hard to believe Mint 17.3 has not upgraded from 5.0.x as I have seen most distros delivering 5.4.x versions. Do you have updates turned off?

Got your file. Got the error. Looked inside & found the .odb has been opened with HSQLDB v2.3.0. Now Base comes with HSQLDB Embedded v1.8.0 so something has changed. The shipped HSQLDB was changed, a class path is present, or the .odb was opened with another product which has a different HSQLDB.

I’ve uploaded the database. It’s just a list of books.
I can create a new database, close it and open it again. However when I did it originally I used the table wizard and selected Personal->Library and added some fields, then clicked finish. I then went into edit mode and changed some of the fields’ names and types. I had a problem with the primary key, and it took trial and error before I could save the table. I’ll try to remember the exact steps and add to the original question

Well that’s strange because I only opened it either by double clicking the file, or going through LibreOffice->Base

On this new Base file you just created, please create a simple table. Then save the Base file, close it, open it and access the table.

Done that. No problems. I can open/edit the table without errors.

Well, I have no idea how it got that way only that it is. Here is the internals I found:

#HSQL Database Engine 2.3.0
#Sat Nov 04 19:58:39 GMT 2017

You should be able to get this working again by following my answer on this post. Remember, always work with a copy. Keep original safe until done. If not, I’ll see what I can do.

That is strange because I’m sure I’d stopped working on it by that time. I really appreciate you taking the time to look at this. I’ll let you know how I get on

Ratslinger, You Sir, are a gentleman and a scholar! I have downloaded your working version, made several copies and am pleased to announce that I can open by doubleclicking and by opening through LibreOffice Base. And even more importantly I can close down and open again. This is what I would call over and above the call of duty. If I could upvote you more I would. Thank you.

You are quite welcome. Just glad to be of help. I do wish to understand how this happened (not expecting an answer from you).

I have the exact same problem as Webbie 4. I have a database used before and now all of a sudden can’t with the error message in the header of this post.
When I examine the .odb file using an archive utility and open /database/properites with gedit I get:

'#'HSQL Database Engine 2.3.0

'#'Tue Dec 05 08:33:28 CET 2017



When I create a new database with my current libre-office base version which is Version:, the properties file has:

'#'HSQL Database Engine
'#'Fri Jan 12 16:41:32 CET 2018

So obviously the error message is correct but how it got that way I have no idea.
Is there a way to change my setup in a way that I can open both types of databases?
If that’s not the case is there a way change the settings so that I can read the database created wit the 2.3.0 HSQL Engine?

@ewald You have basically asked this question before and never responded to the answer (posted here)

Please do not ask questions in an answer. Answers are for responding to original question. If this is in fact a NEW question, ask as a New question and also if related to another refer to the related post.

Sorry for misbehaving, I’ll try to do better in the future. Helpful would be a way to list own posts and an e-mail notification for new comments/answers I know about the “follow” button but it doesn’t seem to work in my case.
As for this very problem of mine: what should I do now should I transfer my “Answer” to the original question since it has new diagnostic material and most importantly for me of course is there a solution?

Yes you should transfer the data to your original question (copy from here; edit original question and add text there; don’t use Answer to add data to question).