The cursor jumps and selects randomly

I use mouse and bluetooth keyboard and have no such issues using any other program but Libre Office.

When writing a document you click on a word or a paragraph and mostly it will jump and also select a whole line or word and move to the end of selection, or just move without selecting. Once it is there it stays there until I try to move it again. I just can’t figure out its logic and it is driving me insane. You can’t use mouse, only keyboard 100% while editing. No such issues happen with other apps. Well except maybe on this particular page where it decides to change page as you type in the search box without any sense. And no, my keys are not stuck.

OSX 10.15.17 LO

And finally how many ridiculous pictures do I need to click to get anything done??!?

My macbook pro is shut closed. So obviously I don’t use trackpad and don’t come near it. And my mouse behaves perfectly outside of the LibreOffice. I use Photoshop a lot and you could imagine what would happen with my work if with a similar problem. I don’t know what it is but suspect Libreoffice is trying to do something very clever like some smart selection and ends up being super dumb. Is there a way to just disable all predictive tools, AI assistance and all that?

“My macbook pro is shut closed. So obviously I don’t use trackpad and don’t come near it.”

Sorry my crystal balls broken.

Sounds like the shift key is getting stuck down. Could be mechanical, could be something between lid and keyboard, or maybe you have Sticky Keys enabled

What computer are you using? I ask because what you describe is a problem many MacBook Pro users describe, myself among them. There is a lot of discussion about this on the Mac Help site. It is maddening. I found that if I plugged in a mouse the insertion point stopped jumping. The problem seems to be the track pad. Good Luck.

This is clearly not a solution to the problem but a comment. Note that the site engine has reordered the “answers” in a last-in, first-at-top fashion, thus losing chronological order. This is a Question & Answer site, not a forum.
There is no conversation here.

Please, click on the more link below your “non-answer” to Repost as a comment. Do this first so that chronological order can be restored.

It recognises the problem and offers one solution; that sounds like an answer to me

@ajlittoz, By my little experience in the site, when an answer is reposted, it take its chronologic place no matter when it’s done.

It doesn’t offer a solution unless it is to rip out the internal cables for the trackpad and then use credit card to buy an alternative machine. Having trackpad on a laptop (not even using it) should not disqualify it from running libre office.

Disable the trackpad when mouse is plugged in, might be default?

Many hits when I search for Macbook Pro cursor. One answer on Apple.Stackexchange sounds reasonable (about halfway down the page) and that doesn’t involve slapping the trackpad,

Whatever. I’m sure it will be fixed in V9 by accident or so. No point even trying to investigate.