The Syriac script does not seem to be included. How do I include it?

  1. version English, writer document
  2. Windows 7 Professional, 64 bit, SP1; English
    And also Windows 8.1 Pro, 64 bit; English

We are working in two languages. Their ISO codes are “aii” and “tru”. Both of these languages use Syriac scripts.

When we paste Syriac words into Libre Office, some of the characters do not look correct in Libre Office There are spaces in the middle of words, some characters are doubled and the point size is wrong. Mangal 12 font is substituted for some of the characters we are pasting, but we were using different fonts at a different point size. These fonts look fine in all the other applications we are using.

Here are some phrases that does not paste correctly into Libre Office.

ܟܬ̥ܳܒ̥ܳܐ ܩܰܕ̱ܡܳܝܳܐ ܟܬ̥ܽܒ̥ ܠܺܝ، ܝܰܐ ܬܶܐܳܘܦܺܝܠܶܐ

ܗܰܢܳܐ ܒܽܗ̄ܘ ܪܺܝܫܳܐ ܣܶܕ̱ ܐܰ‌ܠܳܗܳܐ ܗ̄ܘܰܐ

Thank you in advance for any help you can give.

I am not a specialist for your language but it sounds to me that you do not have the needed fonts installed. You must install the right fonts following the procedures for you windows 8.1 OS. LibreOffice can pickup the fonts

Additionally you might need to set your language in

Tools > Options > Language settings > Languages and also in Complex Text Layout.

You will also find information in the guides. I recommend to have a look at the free guides which you can download from