The top menubar is corrupted

Recently the top menubar became corrupted while using LO.
It appears transparent - it shows desktop image, clicking on menu items (which are difficult to read) results in highlighting that follows the mouse cursor down the menu.
Menu items still work OK.

I tried deleting my ~/.config/libreoffice folder and starting again, no good.
All users on this PC are affected.
No other computer (all runing Fedora 30 and current LO version) are affected, so it was not a corrupt update as I first thought.

No configuration was altered - it just blinked in the middle of a document and became corrupted.

Just a guess, are you using a different theme in this Fedora than your other Fedora systems? LO follows the system theme unless you override it. And you deleted /.config/LO

No. Nothing changed, same theme across users and distros and has been in use for some time. The corruption occurred in the middle of editing a document and is now persistent and across all users on that system. Tried reinstall and also uninstall/install but no good. Reinstall/fresh install with default (horrible!) theme displayed exactly the same fault.

No idea why, but after the second routine Fedora 30 update over the past couple of weeks, the problem disappeared and the menu bar is now back to normal.
Noting that an uninstall/reinstall still displayed the problem.
I’ll just put it down to one of those things…