Toggle formatting marks does not show no-break spaces U+00A0 nor spaces U +0020

Hi, for some time now I have noticed that although Toggle formatting marks is pressed, instead of seeing a grey space for no-break spaces U+00A0 and a blue dot for spaces U +0020, I only see the background. Wordjoiners are correctly displayed.
Could anyone point to its cause?

This is a sample text:

1. Lorem ipsum dolor⁠-⁠sit amet,

And the way it shows:

Screenshot 2023-01-25 at 11.11.57

I am also attaching the file.
Lorem Ipsum test for Asklibreoffice.odt (16.7 KB)

Version: / LibreOffice Community (Aarch)
Build ID: 85569322deea74ec9134968a29af2df5663baa21
CPU threads: 8; OS: Mac OS X 13.2; UI render: default; VCL: osx
Locale: it-IT (en_IT.UTF-8); UI: en-US
Calc: threaded


For an obscure reason, visual feedback for no-break space is controlled by View>Field Shadings.

What is displayed by View>Formatting Marks can be further configured by Tools>Options, LibreOffice Writer>Formatting Aids. See if Spaces and Tabs have been unticked.


Great answer @ajlittoz activating that solved the non-breaking space invisibility. Tabs and normal spaces are still invisible though. Any ideas why?

@ajlittoz great, that did the trick. I guess that these options were changed by default in/by the latest installation (or I must have done something without realizing it), since I had no idea where they were before now. But now everything is as I needed it, thank you for your help.