Toggle highlight cells used in a formula, when clicking in the cell with the formula?

Up to recently when I clicked in a cell containing a formula, then clicked in the input bar, all the cells used in the formula were highlighted in colour and the formula was displayed in the cell using corresponding colours.

However recently one of my files no longer highlights the cells at all. The details of the formula are displayed, but in black. No other cells are highlighted in any way, whether I click in the input bar or double-click on the formula cell.

It works in other sheets in the same file and in other files so it seems like it must be a local setting but I cannot find how to fix it.

After searching in the forum here I have tried :

  • updating from 5something to : no change
  • double-clicking in the formula cell instead of clicking in the input bar : no change
  • copying the data from the affected sheet(s) to a new sheet : this works until I save, then it stops working.
  • copying the data to a new file : also works immediately after pasting, then stops working.
  • Tools > Options > LibreOffice Calc > Display (? my app is in french so I am guessing at the english name), “display references in colour” (again, a translation of what it says in french ; last option in the first section) is selected.

PLEASE HELP this is a big problem for me.

Please file a bug report with the problematic file attached.

Ah. I guess this means there is not an easy way to fix this. Okay I will file a bug report, thanks.

For info, for anyone else experiencing this, my problem was RESOLVED by restoring my user profile following these instructions :

Checking the user profile for corruption is suggested at the very end of the bug report page so two suggestions :

  1. suggest checking this before suggesting a bug report, and / or
  2. the suggestion to check user profile for corruption should be placed at the TOP of the bug report page.

I had already written out the entire report and created an anonymized file specifically to submit and the whole process was somewhat time-consuming, and it turned out, unnecessary. :confused: Anyway problem solved, hopefully this info will help others with the same bug in future.

EDIT : I am unable to mark this as the correct answer because I don’t have enough points apparently, could someone else do that ?

You can’t mark your own answer as correct, obviously… and someone else than the original questioner can’t before a waiting period of 3 days.