Too much fonts (lags, poor user experience)

Hello everyone,

In LibreOffice Writer, I have too many fonts available. Every time I try to select one (to give some relief to this or that line in my text), I end up with a drop-down menu that is much too long, with too many choices. In fact, there are so many fonts available that my computer slows down.

My question is: what should I do to remove some fonts from my LibreOffice?

For information:

  • My OS: Debian GNU/Linux 11 bullseye (x86-64) (Cinnamon 4.8.6)
  • My PC : Intel i5 7200u - 8Go DDR4 - SSD
  • LibreOffice (Linux)

(I have a Windows 10 PC with LibreOffice and I don’t have this problem)

Thank you.

Fonts are normally managed by the operating system.
Make fonts inactive in your operating system or delete or save them to another location.


This problem won’t occur if you format your document with styles. You design your style set (or customise the built-in ones) before creating your document. With styling, you no longer need any of the formatting menu. Using the menus or the keyboard shortcut is called direct formatting. DF leads to oversized documents (compared to styling) and formatting nightmare because you can’t tune your formatting and layout centrally (playing only with style configuration); you must scan manually your document to review it and change the formatting where it is located.

To mitigate the issue, Tools>Options, LibreOffice>View. In Font Lists section, unitck Show preview of fonts so that LO won’t try to read all font files to draw a sample.

This little trick does indeed relieve my CPU a bit, but I lose the visual preview that allows me to choose a font according to what I’m looking for…

Interesting. It is a very “professional” solution that I will test soon. Thank you!

That’s it! Thanks for teaching me that!

From there, I was able to solve my problem. Indeed, my OS (Linux Debian) offered me too many fonts, including too many that were not even compatible with my language.

Here is what I did to remove the excess of available fonts:

a) I installed on my Debian the “font-manager”, “font-manager-common” and “nemo-font-manager” packages from the Synaptic package manager. (No need to use the terminal, you can do all this with the GUI).

b) Then I launch “font-manager”. font-manager is - as its name suggests - a font manager that allows me to see all the fonts installed on my OS… and to disable the ones I want to disable.

c) So, I deactivate all the fonts of my choice, especially those which are unable to display correctly the accents of my language. (This operation was quite long to do, and it requires a lot of the CPU.)

d) I close font-manager, I restart my computer, I launch LibreOffice… and that’s it! The font drop-down menu has been cleaned up. Much less choice but much more consistency, and lightness for the CPU.

Thanks to Hrbrgr and ajlittoz for their help. :ok_hand:

1 Like