Tools Language hebrew not working

In Libre writer Mint 18, font NotoSansHebrew shows in Hebrew Aleph-Beit Ivri but no other Hebrew font and fails to type any hebrew.
I chose the only this document and various language change shortcuts- Alt+Caps and toher combinations, nothing worked

Hello @ezzrraa,

Other fonts also can have a subset for Hebrew.

Just make sure that you have selected “Hebrew” in your system’s Text Entry Settings, then start typing some text in LibreOffice Writer.

It automatically changes to a font that has the Hebrew Unicode subset, in my case it changed into “FreeSans” and the characters are Hebrew.