touch pad right button stops working when LibreOffice is launched

This is a Lenovo laptop 510s running Ubuntu in both 17.04 and 17.10. It is one of those peculiar things.

I have the synaptics touchpad set for manual clicks so as to avoid problems with palm clicks. Before running libre office, pushing down and getting a click on the left of the mouse pad gets the left button, pushing down in the middle gets the middle button (right and left simultaneous), and pushing the right gets the right button. This is one of those touch pads that is a single unit but flexes at the bottom for physical button pushes.

After LibreOffice launches, the right button stops working. The left button continues working This is a problem when trying to spell check as the spell check options are right clicks. After LibreOffice shuts down, the right button still does not work. It will not start working again until I reboot. My cure is to carry a usb mouse with me, and when I run LibreOffice, and after, I plug in the USB mouse. All the buttons on the USB mouse always work.

It started with 17.04 and I figured it would go away with some update. Two years later and now running 17.10 it is still doing it.

Is there a work around for this. And yeah, it would be nice if someone fixed it …