Trouble opening another file

I’m currently using LO on Zorin Linux (a Ubuntu / Debian variant). I’m not sure when this started. I open a file I created in LO and work on it without any troubles. After about 10 minutes if I open another LO file in Writer or Calc the file won’t open but will show the little flash screen which flashes on and off. This keeps up until I close the first file. Then when the 2nd file opens I have to go through the File Recovery process for the file I just closed. However, if I open the 2nd file within a few minutes of first opening the original file this problem doesn’t occur. It matter not what 2 files are involved. I’ve experimented with this a few times and it seems the point where the trouble starts is AFTER the file I’m working on has been saved or had an autosave event occur. Opening more files before that has no problem. I only use Writer and Calc, so I don’t know if this affect the other programs. It wasn’t a problem at the start of the year, and I’m not sure how long it’s been an issue as I’ve always been too intent on getting the work done to report it until now. I can say, for sure, it wasn’t an issue with any version of LO 5 and it has been an issue with all of the LO 7 versions I’ve used. I don’t think it was an issue with LO 6.5, but not sure.

Does the problem accure in Safe Mode ?

I don’t know, as the only time I get an option to open a file in safe mode is after a crash occurs. Then I simply go through the standard Recovery actions. When this problem I mention happens I simply close down every instance of LO and then reopen the files. It’s damned annoying and wastes time, but it’s not critical; which is why I haven’t worried about it until now when it got at me on a bad day.

You can switch to Safe Mode any time via Help > Restart in Safe Mode try doing that and see if the documents behave the sameway when you are in safe mode. Report back with your results. :slight_smile:
And to switch back just Look in the Help Menu again. Restart in Normal Mode or something.

OK, I did as you asked. LO came back with two windows (a) A list of Recent Documents, and (b) a Notice about being in Safe Mode and giving me options on how to continue in Safe Mode.

I clicked on ‘Continue in Safe Mode’ and only the original document opened along with an Error message of, quote,:

Error loading BASIC of document file:///home/ernest/.config/libreoffice/4/user/basic/Standard/script.xlb/:
General Error.
General input/output error.

end quote

and the only option on the box is ‘OK’ - I click OK and get an instant repeat - click OK again and the other file opens in Safe Mode.

Interestingly, in Safe Mode the Standard Toolbar is the default variant and not the toolbar I personalised that normally shows.

When I go to restart I have to go through the file Recovery process.

I hope this helps someone to identify what is happening and initiate a fix for it.

Try moving or removing the directory: /home/ernest/.config/libreoffice/4/user/basic/Standard/script.xlb/
And try again with and without safe mode. Report back with your findings. Sorry to have to send you back and forth, but that’s what debugging is like. Hope you dont mind too much. Later.

That’s OK. I know what it’s like to debug programs. But I’ve not done it for 25 years, and nothing as complex as this must be.

I removed the directory 4, then I then tried it with the directory ‘libreoffice’ removed. In both cases as soon as I opened a .odt file the directory and all below were recreated and the file opened up exactly as if it was the first time I ran Libre Office 7 without any of the personalised settings.

I checked the code of script.xlb - it is (spaces added to ensure it doesn’t run):

< ? xml version = “1.0” encoding = " U T F -8 " ? >
< !DOCTYPE library:library PUBLIC "- // // DTD OfficeDocument 1.0 // EN " " library.dtd " >
< library:library xmlns:library = " http: // / 2000/library " library:name = " Standard " library:readonly = " false " library:passwordprotected = " false " >
< library:element library:name = " Module1 " / >
< / library:library >

I tried recreating the problem without any personalisation, and no issues. hmm.

Well i guess the file is/wasn’t really the issue. Since my setup has the exact some file.
But did correclty that the issue without the personalisation does not accure? Or did i missunderstand your last sentence?

Since the file it quotes in the error message is EXACTLY like the original in a default installation I doubt the file itself is the source of trouble. But why it’s being reported as such is beyond me.

When I personalize LO I change some of the icons in the Standard toolbar, some of the color settings, and the default save to file location to where I actually store the files.

I’m at a total loss as to why the issue occurs, especially as it only occurs AFTER I’ve been working on a file for a while then want to open another file to check something in it. Weird.

I suspect it’s something related to the ‘lock files’ and the ‘default save to location’ having a conflict, but I have no proof other than a gut feeling.

If you think you can describe the problem good enough, you can report a bug/issue here:
Just search beforehand if nothing similar exists.

Since I’ve not got an answer I lodged a bug report on the matter and am closing this question.