Trying to optimize a broken text

I have an online book wich i got, but it’s text is broken and far degraded to be able to read it comfortably.

instead of paragraphs, i get things like

When i wou like to have “aaa
Ddsedfgd, dfdfdf fdfd dfdfd”

Does Writer have some sort of tool able to fix this or at least get me close enough to it?

Not enough details to give you any useful advice. Edit your question (= modify it) to improve it. Mention OS name, LO version and save format (odt vs. doc(x) or other). Provide a sample of the text or at least a screenshot with View>Formatting Marks enabled.
Usually when you capture text from the web, you get an already processed-for-display stream where the “logical structure” has been replaced by a “display structure”. E.g. paragraphs have been split into lines with hard line breaks at end.
Before fixing text, you need to clearly identify the cause.

You either have line breaks or paragraph breaks at the end of every line. Removing them will solve your problem. One method is to use the AutoCorrect tool. Be careful! This may modify more than you want.

First select all text, then apply the Default paragrah style.

Now, open Tools - AutoCorrect > AutoCorrect Options. Select the Options tab. On the left side are two columns with check marks, marked M and T. You only have to worry about the M column here. Remove the check marks for all options that you don’t want. Do check the option at the bottom (you may have to scroll down): Combine single line paragraphs if length greater than 50%. Close the dialog window.

Now comes the final step: select Tools - AutoCorrect > Apply. This step will join pretty much all lines in a paragraph, but also join paragraphs where the last line of a paragraph is longer than 50% of the regular line length, so you will need to do some manual fine-tuning aka proofreading.


When I OCR a document sometimes part of the text ends up in a very narrow column. It doesn’t worry me because I always Paste Unformatted Text otherwise there is way too much random formatting to manage.

If you select all the text and, in a new document, click Edit > Paste Special > Paste Unformatted text, does the issue resolve itself?