Turn off automatic date formatting in Writer tables

I know how to suppress auto-formatting of date in Calc (e.g., preceeding cell data with an apostrophe), however, this does not work for date-like text entered into table cells in Writer.

Even setting the table/cell format to text, e.g., via Number Format > Text does not prevent cells from being automatically converted to dates (e.g., Aug 29 to 08/29).

Is there way to turn off or otherwise suppress this behavior?


Number recognition?