turn off calc in writer table

Hi, I’m trying to write a document in Writer in which I have tables where cells can contain an equals sign, but when I do that it thinks I’m trying to perform Calc functions, but I’m not. Is there a way to set a table to be pure text to turn this feature off? TIA.

Try this- select the table, right click and set the (number) format to text.

If this answer helped you, please accept it by clicking the check mark :heavy_check_mark: to the left and, karma permitting, upvote it. That will help other people with the same question.

Sorry, that didn’t work. Thanks for trying though!

The advice by @robleyd works for me in LibO Writer V 6.4.2 - cum grano salis.
The situation is buggy, but there is a workaround.
The newly created table shows the format string @ if you look at it. But that’s a fake.
Select the complete table and set any numeric NumberFormat, say #00 first. OK
Same selection, but now set the so-called number formatr Text (@).
The next = you enter should be accepted as a literal character.
BTW: The silly and next to useless selection of formula means (functions, operators) in Writer tables is all but Calc - fortunately.

@Lupp: you are absolutely right. I filed tdf#132111.

You are great in reporting bugs. Thanks in everybody’s name.

No option to disable this behaviour currently exist. The behaviour is hard-coded in SwEditWin::KeyInput.

You are welcome to file an enhancement request.

If it works for your use case, just put a space before it " =" instead of ". I know it’s not a perfect solution, but it is a suggestion. I different things, but didn’t work.