Turn off scrolling in Writer when moving mouse to top/bottom in highlighting mode?

one thing that always irritates me is that Writer scrolls the document up or down when you (quickly) move the mouse to the bottom or top of the document area (without clicking), IF you select the highlighting tool (to change the background color of selected text). It’s not really scrolling, because it’s very fast, more like jumping up or down half a page. Is there any way to turn this off?

Thanks a lot,

The behavior of a mouse is normally determined by the settings of the mouse thus not determined by Writer.

Additionally you did not specify your OS and what exactly you are doing, e.g. are you pressing a mouse button while moving the mouse etc.

Using the highlighting tool also my Writer files (Windows XP) scrolls as soon as I just move the cursor outside of the text window. But the scrolling is not very smooth and for my current feeling not very consistent. Sometimes I can go to the next or previous page and sometimes I cannot.

Next I look into the help file and help wiki and search for information about scrolling settings within LibO or Writer but could not find anything. Therefore, I currently assume that the scrolling behavior is controlled by the OS and mouse settings. I would happily be wrong with me statement when we could get an answer on where to control the scrolling behavior in Writer to make is smoother or to turn it on and off.

Thanks, that’s exactly what I mean. But since it only happens in Writer when you use highlighting, and since it’s totally non-standard behavior, I can’t imagine that it has anything to do with the system settings. I guess it’s a badly implemented feature of Writer.

@Kristy - Please feel free to file a bug report here: https://www.libreoffice.org/get-help/bug/

No, this is a feature of LibreOffice (and already was a feature of OpenOffice when I started using it years ago), it’s independent of the system mouse settings and the same on OSX and Windows, probably also on Linux. It also happens in no other program, so I guess it’s meant as a kind of “smart auto scroll”. And as I wrote, it’s happens when I move the mouse quickly to the top or bottom of the document area (from within the document area), mouse clicking. But then again I can’t reproduce it right now. But I had this behavior yesterday (witht the same document) when I put in the question, and many times on various computers, versions and systems during the last 10 years or so. That’s why I’m pretty sure that it’s not just a bug or specific to my current configuration.

Correction: It only happens when I use the “highlighting” tool to color the background of selected text. Sorry for not specifying this, but I use this so often (to mark text from the net) that it seemed as standard behaviour!