Turned off auto-hyphenation, KEEPS TURNING BACK ON

I’m working in LibreOffice Writer. I love it other than this one thing.

I’m on Xubuntu, latest version (20.04.2), on latest version of LibreOffice Writer (, but had same issue with last version of writer also.

This is maddening, and I’m about to go back to (GASP!) Microsoft Word if I can’t solve it.

I turned off auto-hyphenation using this, which is recommended as default answer on this site, on a page that is closed:
"Format → Paragraph Style → Text Flow and uncheck “Automatically.”

But it keeps turning back on. I am working on a document, it hyphenates, then I check and it’s turned back on!!

So I found this as an answer for individual docs on your site, and did it on the long doc I’m working on for my boss, on a deadline:

"Go to Tools > Options → Language Settings → Writing Aids

Go to the bottom pane “Options” and scroll to the bottom. There you can adjust the hyphenating settings.

In bottom pane, uncheck
hyphenate without inquiry
hyphenate special regions.
check special regions."

Did NOT uncheck
Libhyphen Hyphenator in the first pane. Leave as is or you’ll get an annoying warning every time you open the program.

STILL can’t get auto-hyphenation to stay OFF.

This is so wrong. Why can’t I just turn off auto-hyphenation globally and forever.

Any help is appreciated. Have to turn this doc in soon, boss hates, and will not accept hyphenation, and I agree. It looks sloppy. Only workaround I can think is to paste into Word, fix, and output. But if he wants a single change, I’ll have to do that again.

I talked him into letting me use LibreOffice, and have been talking it up to him. Tried to get him to install it on all Windows computers in office. Almost have him convinced, but it he does and this happens, I’d be on his list of people to not trust with computer help. That would be BAD.

It would also reinforce his belief that open-source anything isn’t as good as Microsoft (!)

Please help!
Thank you.

First an explanation of the experienced behaviour.

When you Format>Paragraph, Text Flow tab, and uncheck Hyphenation Automatically, you apply a direct formatting (a one-time manual formatting) to the paragraph where the cursor is. Eventually, if you press Enter in this paragraph to create new ones, this setting will be kept in the new paragraphs but it does not affect existing ones nor new documents.

What is surprising is hyphenation feature is enabled because it is disabled by default. This means you somehow altered this default and recorded it.

Now the fix.

  1. Open a blank document
  2. Make sure the side style pane is visible (F11 or Styles>Manage Styles)
  3. Right-click on Default Style and Modify
  4. Go to the Text Flow tab and uncheck Automatically hyphenation box
  5. OK

Changing Default Style configuration applies also to all other styles because it the common ancestor from which all styles inherit.

To make this setting the default for new documents, you need these additional steps:

  1. File>Template>Save as Template (instead of the traditional File>Save) and give it a name you like

    This saves the “document” in your user profile so that it is known by LO as having special properties.

  2. File>Template>Manage Template, right-click on your saved template and Make Default

Close LO. Open Writer and create a new file. Check that hyphenation is now turned off.

When you install LO from scratch on a computer, see if hyphenation is turned off by default (this is standard factory setting). This should avoid the procedure above.

Special caveat for Windows

If you really need to follow the above procedure on Windows, be aware that creating a new Writer document direct from the desktop will not reference your customised template. This is a known bug and the cumprit is Windows, not LO.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!


Thank you.

Your workaround worked for new documents.

But my old long document for my boss is still hyphenating. I even tried highlighting the whole thing and clicking on “Default Paragraph Style” from the drop-down menu near the top left.

Is there any way to fix a document already created with hyphenation?

And I did turn it off many times, it kept turning back on. Hopefully it won’t turn back on, but it seems to be turned on for this one document.

Even manually fixing each hyphenated line won’t work, it reverts to hyphenated.

Thank you.

From your usage of Format>Paragraph, I infer you commonly manually format your documents (a la Word) instead of using styles. Direct formatting takes precedence over style formatting. It results from that changing Default Style will have an observable effect only if you have not tried to “fix” the situation manually on paragraphs where hyphenation happened. And remember that disabling hyphenation changes text layout, potentially causing new hyphenations in other paragraphs.

You can remove direct formatting by select all your text Ctrl+A then Ctrl+M but this will also erases all your typographic manual formatting such as bold, typeface, size, …

In a professional context, you have no other choice than learning to style format otherwise you’re facing insurmountable problems like the one you’re presently facing.

To diagnose if the issue has other causes, you should attach a file but I fear it is confidential.

Thank you.

Styles is a Word feature, not just an LO feature.

I tried using it with LO, but had an issue with that, and abandoned it, where making a TOC and it didn’t update even when following directions exactly.

Yes, the document is work product, I can’t share it. I appreciate your offer though.

I’ll see how many hyphenations there are and see about manually fixing them, hopefully it does less damage and not more.

More exactly, Word knows only of paragraph styles whereas Writer offers also character, page, frame and list styles. The consequence is that in Word you must apply variations inside paragraphs with manual formatting while this should be done with other styles in Writer. This aspect is too often neglected by people who switch to LO and leads to situations like yours. I suspect it originates in some inconsistent use of paragraph styles first and to a mix of style and direct formatting.

Writing professional documents supposed to be maintained over a “long” period requires a strict writing discipline where direct formatting is forbidden. This is the hardest part of the procedure and it is very difficult to convince colleagues this is the only way. Usually “switchers” are not aware of the strict styling approach benefits and think it is difficult. Once you get used to it, you wonder how you could write before without it.

Thank you. Now I know.

I’ve exported this doc to Word, gone though and made it work with company style. That was the only solution on a deadline.

Will work with LO on my own at home and try to learn all of it. I like it a lot, and love open source.

Is there a way to turn off that extended behaviour to get it to work like Word? I’d guess you’d say “Why in the world would you do that?”

The answer is “There is no way I’m going to get the whole company to learn that, but if I could set it up with IT so it behaves exactly like Word, they might switch to save money. Especially since company contracts are down since pandemic.”

I would let them know about the additional function, but they’re not going to switch if everyone has to learn new tricks.

Thank you for the help.

There are two ways to address Word “compatibility” but this will not be 100% because the suites are based on different principles. The idea is to mitigate the discrepancies.

First explore Tools>Options, LibreOffice Writer>Compatibility. Not all options are related to Word; experiment to find the “best” combination. Remember this configuration will have to be installed on each computer but this is a one-time operation.

The second lead is both more general (in the principle) and more specific (meaning user-customised). You can create templates defining company stationery for letters, reports, invoices, … also containing the styles needed to render “company style”. One of these can be made default. However if the PCs are under Windows, creating a new document from the desktop doesn’t reference custom default template but only the factory default. This is a known bug for which Windows is responsible. A workaround exists but requires intervention on every machine. Once only.

Thank you for the detailed and useful answers.