Two spaces after a period

So this seems very basic and I am surprised there is an issue here. Two spaces after a period is what I’ve always been told and its a requirement for most educational institutions, regardless as an end user it should be my choice. If I ignore double spaces writer simply ignores the second space and I get one space. If I don’t ignore double spaces I can enter two spaces; however, the spell checker flags it as an error. It certainly is not an error and is confusing that it shows an error. Do I have three spaces by accident, is there some other reason there is an error there? How can I get the spell checker to understand that two spaces is not an error?

Country depending double spaces are used.

You change settings:
Tools > AutoCorrect Options > see screenshot below:

Check Ingnore double spaces.

So that’s where it was hiding. Driving me nuts. Thought it was a setting or and add-on. Thank you.

This does not seem to be the right place for a comment – it says, “Your Answer.” My apologies. If you would, please, where do I enter a comment about an answer or question, but not an answer?

Well - obviously, using “[+] add a comment”

Thank you, but if it were obvious, I would not have needed to ask.