Ubuntu 20.04, no menu bar in LibreOffice

I just installed Ubuntu 20.04 and noticed than in GNOME Flashback graphics environment there is no top menu bar (File, Edit etc.) in LibreOffice. In GNOME Shell the menu is displayed, but I don’t like GNOME Shell and want to use GNOME Flashback, which I’m used to.
Someone here suggested to turn off options like OpenGL, OpenCL or hardware acceleration - all this doesn’t work for me. Someone else suggested to uninstall libreoffice-gtk3 package - that indeed brings the menu back, but also loses all styling from the currently set GNOME theme. The application has an ugly, “raw” X toolkit look.
How to fix this, ie. bring the menu back while keeping the system theme? The application is hardly usable without the menu.
BTW. I even installed the newest version of LibreOffice from the PPA instead of the default one from Ubuntu repositiories, didn’t change anything.

Issue solved. The problem was that Ubuntu indicator-appmenu applet somehow got added to the top panel. That applet should normally display (for some applications only, and most notably LibreOffice) application menu in the top panel instead of inside application window, but due to the dependency bug a required component was missing and the applet was empty (and therefore invisible).
Removing the applet from the panel restored the menu back inside the application window.

I have a similar problem, but I’m on Xubuntu 20.04 running Xfce4. Can you explain what you mean by “Removing the applet from the panel” (the LibreOffice panel? the Window Manager panel?) and exactly how you did this. LibreOffice is the only application displaying this problem. Thanks.

By the way, I uninstalled the entire indicator-appmenu package and the menus were not restored in LibreOffice.

Well, I decided to uninstall the indicator-appmenu package again and then rebooted. This solved the problem.

Is this package used for anything with the xfce4 system, or is it just specific to Gnome?