Ubuntu LibreOffice does not recognize Windows partition of Dual Boot system.

LibreOffice does not recognize folders or files on the Windows partition of my dual boot Ubuntu/Windows system, though no other apps in use have the same problem.

I am running Ubuntu 18.04.1 LTS. System dual boots with Windows 10. Data files are held in Windows partition. All data is readable/editable by other Ubuntu applications. It is important that the data files be accessible from both Ubuntu and Windows, so copying them to the Ubuntu folders is not a solution.

Working from: LibreOffice, build ID: libreoffice- Selecting LibreOffice Write’s File / Open…
shows files in Ubuntu’s Home, Documents, Downloads, Music, Pictures, Videos folders (Files can be opened and edited from any of these Ubuntu folders), but attempting to access a folder on the Windows partition produces an error:

“Could not read the contents of mnt”
“Error opening directory ‘/mnt’:
Permission denied”

PROBLEM 2: Working from Ubuntu’s Nautilus file manager. Double-clicking on a .doc or .odt document file in the Ubuntu Documents folder successfully opens the file in LibreOffice Writer, but double-clicking on a document file in the Windows partition produces an error:

“/mnt/Windows/[…/filename] does not

I have seen similar problems discussed (one related to gnome integration, another to removable USB media). And I have noted that some from years ago have been closed as duplicates, with no further guidance provided. If my question is a duplicate, I would very much appreciate being directed to a discussion that resolves the issue.

No experience with Ubuntu (which is somehow different from other Linux distros) but have configured dual-boot for friends (though no W10). Have you checked the permissions on /mnt as the error suggests. Do the same on Windows side to ensure the directories/files are “world” (ie. other than user or group) read/wrrite enabled. User and group IDs are not the same on W10 and Ubuntu which could be the source of the mess. They translate to small integers and the same name can easily map different.

Thank you for the suggestion. I don’t see any permissions problem. BTW, is there any (good) reason that LibreOffice would be using a different set of permissions than every other app in Ubuntu? File manager, text editor, GIMP, Sublime Text, Filezilla, Inkscape, etc., all are able to open Windows partition folders and access (read/write) the files within them. LibreOffice is apparently not dealing with files in a standard way, and I cannot imagine a reason.

I will note that LibreOffice ran reliably with the same setup and the same files before the recent upgrade to the stated versions of Ubuntu and LibreOffice.

LO doesn’t implement its own set of permissions. It relies on the OS. So, something weird should have happened during the update.

Noticed that the LO install is putting configuration files in a /snap/libreoffice/80/.config folder. Is that right??? I read that the files should be in a location that looks more like .config/libreoffice/4/user . I tried removing & purging LO and then reinstalling. But same situation results. Still no access to Windows partition.

That’s why I say Ubuntu is peculiar. Distro vendors are free to choose the location of config files.

How do you mount your Win partition? Manually or through an entry in /etc/fstab?

It’s set up to mount automatically on boot-up.

Must be something kooky going on with LO (the software center actually has a separate “Permissions” button for that one - so they ARE doing something weird). I removed everything LO-related from the system and reinstalled from the software center. Got LO v. It works.

Still unable to access Windows partition files with LO
But I installed from the LO website, and that works well.
Wish I could figure out what the problem is in the