UI scaling issue


I have an issue with UI scaling in LibreOffice moreover cursor position is upper than target.

Appdata purged nothing happen… This is a fresh install.

I tried this and it worked for me (except now the font is messed up a little): Tools → Options → View → uncheck “Use OpenGL for all rendering”

I have a similar issue: Blurry user interface on Windows 10

Same here… :confused:


Same thing as szakacsg here. I can solve it by disabling OpenGL, but LibreOffice has an annoying flicker with OpenGL disabled. I suspect there is a UI scaling configuration somewhere, but I didn’t find it anywhere.

Tested with 5.2.6, 5.3.x and 5.4.0, similar results.

System: Windows 10 PRO 64 bits, i7-7700K, Gigabyte GA-H270M-D3H mobo, LG 29UM68-P ultrawide monitor, analog 1366 x 768 monitor.

Same problem, fresh install on Windows 10. Extra notes:

  • Vertical scaling problem only
  • top menu bar placed too high (fully under window title bar), bottom status bar 60% too low (partly outside of windows area)
  • Shown cursor and actual cursor focus are offset, but different depending on relative height in the screen: focus is a couple of dozen pixels above the cursor on the top of the screen, but is only a few pixels off near the bottom.
  • Problem occurs at Windows 10 display scaling setting 125%, but also at 100% scaling.
  • This isn’t a high-DPI issue per se, as I run 1980x1020 (on Intel HD Graphics 620 video chip);
  • Problem is NOT present on another laptop (that uses Nvidia video chip)
  • Also see the problem disappear when unchecking “Use OpenGL for all rendering”. Perhaps an unfortunate interaction with the Intel video driver?

Posted the same thing: LibreOffice DPI is off

Same thing here but it’s easy to fix.

  • Alt + F12 (brings up the settings). You will need to do this because the top menu is invisible.
  • Navigate to “View” (LibreOffice–>View)
  • Uncheck “Use OpenGL…”
  • Hit “OK” and the program will reload and now everything is fine.

Navigation can be a bit tricky as the mouse pointer is a bit off but it’s possible anyway.

worked for me, thanks

I had the same issue running LibreOffice 6.1 under Ubuntu 18.04 and I solved it installing libreoffice-gtk3 package through Synaptic Package Manager.