Unable To Change Font Color Using Mouse

Hi. I’m using LibreOffice 7.2.1.2. I have problem changing font color, both in calc and writer. Here is my problem description.

I select / hi-lite cell(s) containing text, then I click font color icon and click desired color. It doesn’t work. Both in calc and writer.

I Select / hi-lite cell(s) containing text, then I open Format menu, then I choose cell ( format cell ), then click font-effect tab, then click desired color in Font Color section. It doesn’t work too.

It works when i choose the color by moving “cursor / pointer” in color pallet using arrow button in keyboard.

If this is not a bug, please help me to fix this.
Thanks.

When you are in Calc, do you have View > Value Highlighting, Ctrl+F8, selected? If that is highlighted in the menu you will only see black for text, see Value Highlighting in Help.

Possibly, your user profile is damaged. Does opening LibreOffice in Safe Mode (Help > Restart in Safe Mode) solve the problem? If it does, then back up your current profile and reset it using one of the methods in the linked page.

Value highlighting is unchecked, I have tried to restart in Safe Mode, and reset all configuration to factory settings, but that did not solve the problem. By the way, thanks for your help.

Please tell us:

  • which operating system you are using?
  • from where you downloaded LibreOffice?
  • in which file format you save
    a) the Calc files?
    b) the Writer files?

    Thank you.
1 Like

My guess then is that you have

  • High Contrast set in your operating system
  • In LibreOffice Tools > Options > Accessibility > Options for high contrast appearance you have ticked one or both boxes Automatically detect high contrast mode of operating system, Use automatic font colour for screen display.

EDIT:
After testing the above it was uncertain how to get the colour back in LibreOffice. I had to tick and untick the options and restart LO, untick and then Apply then OK. Eventually, the colour came back but just unticking the LO options and OK did not immediately change the screen text to coloured.

Yes.
It will be helpfull to have a screenshot.

Will Options for high contrast appearance not be reset after that?

It could still be operating system (unknown); in Windows High contrast settings it seems that you can define text colour.
I didn’t investigate too deeply as I find High contrast display somewhat disorientating and it causes problems for other programs, such as XnView

Debian 10 linux operating system. LibreOffice downloaded from Index of /tdf/libreoffice/stable, the nearest mirror for me.

The same here for Calc+Writer, unable to fix with above.
Version: 7.2.1.2 / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: kf5 (cairo+xcb)