Unable to change paper size and orientation


I am having the same/similar problem as the one posted here:

and here:

I run an up-to-date Devuan ASCII rig Linux devuan 4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u6 (2018-10-08) x86_64 GNU/Linux and LibreOffice 20m0(Build:2).

My printer is a Samsung M2020W with the CUPS 2.2.1 server.


In LibreOffice, I am not able to change the orientation and/or size of the page I want to print.

ie: File → Print → General Tab → Printer → Printer Properties → Paper Size => option is greyed out and inaccessible.

File → Print → General Tab → Printer → Printer Properties → Orientation => option is greyed out and inaccessible.

The only way out of this situation is checking the ‘Use only paper size from printer preferences’ box in the Options tab.

ie: File → Print → Options Tab → Options → Use only paper size from printer preferences.

This works well as once checked, the ‘Paper Size’ and ‘Orientation’ options are no longer greyed out and can be set as needed.

But the problem is that this setting does not hold / is not saved in the LibreOffice configuration.

ie: The next time I start LibreOffice, the ‘Use only paper size from printer preferences’ box is unchecked again.

Save for LibreOffice, this does not happen with any one of my other installed applications:

eg: Firefox - Master PDF Editor - Wine 1.8.7-2 and installed applications - Gimp 2.8.18

That being the case, I seems that we can rule out this being a CUPS 2.2.1 configuration issue.

Please advise.

Thanks in advance,


Edited 14:13 -03:00 = fixed a terrible confusion/lapsus =-/
Edited 20181023 = added link with same issue

Please note that this site is about LibreOffice, not “OpenOffice”. Though what is true for one, might happen to be also true for the other.

Hello: quite so. I posted in an absolute rush, sorry - It’s fixed now. Thanks. =-)

Hello: I see the post was closed for reason: not relevant or outdated. I’d appreciate if you’d take a minute to explain. Thanks in advance.

@Hrbrgr: question related to LO; should be reopened? With +1 to “neutralize” it at 0?

Thank you for all the alternatives listed; I tried the last one which allowed me to go through the process, but when I tried to print it still printed in portrait instead of landscape. In the end I became so tired of trying that I have printed my documents in portrait; not really satisfactory but they will have to do until I have more time to try again.

If you really can’t change page orientation, attach your file (or a sample of it with the problem) to your original question and we’ll have a look at it. You can’t attach files to comments.


While the question was closed (thank you for reopening it but still don’t know why it was closed) I found this tidbit in Google’s bowels: link text

It refers to a bug that affects LO from as far back as the release, to this day unassigned.
I believe it is closely/directly related to the issue in my post.

A fellow by the name of ‘seacape’ link text, briefly and clearly summed up the problem:

“The current UI is a recipe for user frustration. Please change it. The default should be that LO automatically honors any settings the user specifies in print Properties. That is the behavior users expect.”

Can’t contribute much else for the time being. If at this stage the bug is still unassigned it may not ever be.

Any ideas?

Thnaks in advance.


For me, the solution was to change the orientation via Format - Page… - Page - Orientation.