Unable to copy records from one table to another in Base

Hi, this seems very basic, but I’m unable to copy records from a table in Base and paste them to a new table. For that matter, I’m unable to paste them as duplicates in their own table either, copy seems to work but cut and paste are always greyed out. Does the autofield that is the table key have anything to do with it? Is there a different way I’m supposed to be doing this?


one way to copy the records of a table is to copy the whole table and paste it.

You can do that in the main window of LO base, where you should choose the table icon which you want to copy, hit ctrl + c and then ctrl + v.

A window with options will show up, letting you choose if you want to make a new table containing the records you copied or add your copied records to an already existing table. In either way make sure that the name of the target table, in the first line of the pop up window, is the right one and modify it if it’s not.

Strangely, I’ve tried that, but it didn’t work right which makes me think there is something wrong with my installation. I would tell it to copy the table including the data, and it would try to do so but then give a message that just said “error, continue copying?”. The table would be there, but with no data in it.

I was having trouble with Base seeing my JRE but I believe I fixed it after following the steps in the answer to this question: [Base says my Oracle JRE v1.7 is defective. Is there a different one?](Base says my Oracle JRE v1.7 is defective. Is there a different one?

After fixing the JRE, I could create new databases without it giving me a JRE error, but It still wouldn’t copy tables or records.

Another possible reason for this error is that the tables have an auto-generated key field. If this is the case you must exclude that field from the copy.