Unable to create new Impress file due to insufficient user rights

  • Linux Mint
  • Libreoffice
Object not accessible.
The object cannot be accessed
due to insufficient user rights.

Opening LibreOffice Impress or choosing File->New->Presentation causes above error

I am unable to locate the wrongly permissioned file and do not wish to carry on running LibreOffice as root.

How can I investigate, please?

Where are you trying to open or create this file? Do you have write permissions in that folder?
Step up one folder level from your desired document location and view the folder properties.
Look at the ´Permissions´ tab, who is the owner of your target folder? It should be you. What are the folder and file Permissions ? Those should both be at least Owner: Read and Write.
If you are NOT the owner, and should be, open the upper level folder as root, and in the Permissions tab set yourself as the owner and Apply Permissions to Enclosed Files.
If you ARE the owner with Read and Write on both Folders and Files, then I´m stumped.

The error comes before it tries to open/create a file, e.g. just opening Impress (which I assume creates a blank file that I can later save if I use it). Therefore I can’t give you any further info about where or what permissions etc.

Lets take a step back. Can you open a CALC or WRITER document? If not, do you get the same error? This looks far more likely to be a Linux file access permissions issue than an LO issue.
IF you can open a CALC or WRITE document, look in the Tools menu, at
Options, LibreOffice, Paths
you should find an entry ´My Documents´ which should default to /Home/You/Documents
If it does NOT point to your /Home folder that may be part of the problem.
If you CANNOT open ANY LO document you need to move your question to the Linux Mint forums.

I can open writer, calc etc. And create new files. No error.

“My Documents” is /home/adam/Documents (i.e. in my home directory)

OK, that leaves the inference that Impress is trying to use a resource that it does not have permissions to do so. Strange, I am not aware of Impress using anything that is not included within the LO install. Hopefully someone with better knowledge of the LO package will respond. Sorry I could not help, but we have at least eliminated a few possibilities.

1 Like

My hope is that someone who knows what the code does when Impress creates a new file will know where Impress is trying to access the file system and I can check those directories for files with the wrong permissions.

I assume it’s just Linux Mint and / or apt causing a problem, I rarely do anything with the file system myself manually these days. But I need to know where it’s happening to have any chance of solving it.

The templates dialog is what I get when I’m going to create a new presentation. Cancelling the dialog gives a blank presentation.

Try File>Templates>Manage Templates [Ctrl+Shift+N] and choose some presentation template.
The templates on that dialog are saved in /opt/libreoffice7.4/share/template/common/presnt/ which might be /usr/lib/libreoffice/share/template/common/presnt/ if you are using the ppa version that is shipped with Mint.

Yes, they are in the Linux Mint /usr/lib/libreoffice directory as you state.

I also have one template in /home/adam/Templates which I can see when I call up the Template management dialog from Write. I checked the owner & permissions & all is OK.

However I don’t get as far as the Select a Template dialog when I’m opening Impress.

It is a Mint issue, I suppose.
ls -l /usr/lib/libreoffice/share/template/common/presnt/
should display all templates with read permission to everyone (last “r” in rw-r–r–)

What happens when you call the templates dialog via File>Templates>Manage… and then switch the filter to “Presentations” and “All categories”?

Libreoffice just showed all the presentation templates as though there was no problem. So I double clicked on one presentation template, and it opened a new untitled presentation.

I then closed Libreoffice, and opened Libreoffice Impress and it opened without an error. The problem has disappeared.

I hesitate to say that it solved the problem, because I don’t know what happened. However the problem is gone, I shall mark this as the solution.

Thanks! Fortune smiled on us today.