Unable to disable splash screen on Debian server

Hi everyone,

I hope someone can help me with this, since I have spent many hours researching this issue. I can’t believe I would be the only one to have encountered this issue.

I’m on a Debian headless server (no GUI) and I’m trying to start a libreoffice process for JODConverter. The issue here is that no matter what options I use (–headless --nologo --nofirststartwizard etc.).

It’s a service installed on the server which uses the following command line to start libreoffice:

/usr/lib/libreoffice/program/soffice.bin --accept="socket,host=,port=8002" -env:UserInstallation=file:///www/sites/placedesarts.dev.libeo.com/exo_core/temp/.jodconverter_socket_host- --headless -nocrashreport --nodefault --nofirststartwizard --nolockcheck --nologo --norestore

The service simply says in its logs “org.artofsolving.jodconverter.office.OfficeException: failed to start and connect” as an error message (ok, not true since there’s a whole stack trace but I’ve researched these error messages but found nothing to help with my situation).

I’ve made my own troubleshooting and noticed that the splash screen is still launched in my headless environment with the headless options specified for libreoffice. The command line I use is shown above, here’s what I see in the processes after executing it:

root     26449  0.1  0.0  66540  2116 pts/0    Sl+  13:49   0:00 /usr/lib/libreoffice/program/oosplash --accept=socket,host=,port=8002,tcpnodelay=1;urp -env:UserInstallation=file:///www/sites/<company_domain>/exo_core/temp/.jodconverter_socket_host- --headless -nocrashreport --nofirststartwizard --nolockcheck --nologo --norestore --invisible
root     26466  1.0  0.8 346464 36004 pts/0    Sl+  13:49   0:00 /usr/lib/libreoffice/program/soffice.bin -env:UserInstallation=file:///www/sites/<company_domain>/exo_core/temp/.jodconverter_socket_host- --accept=socket,host=,port=8002,tcpnodelay=1;urp --headless -nocrashreport --nofirststartwizard --nolockcheck --nologo --norestore --invisible

Until I kill the “oosplash” process libreoffice won’t be listening to port 8002. Once I kill it, I can see libreoffice listening to the port. This is when I start the process manually but my issue is having a service using JODConverter start and connect to libreoffice for documents previews.

Is this a known issue, is there a fix or anything which can help me at this point ?

Don’t hesitate if you need more information.

Oh, my version of libreoffice is → LibreOffice 430m0(Build:2)

Thanks in advance,