Unable to edit field info after saving new table

I’m referring to the information you see in the table design view. Field name, field type, field properties, etc. (See paragraph 2 of my original post.)

I just tried uninstalling LibreOffice and installing 7.2.x, and I still cannot edit existing field information. It’s all locked/disabled for editing once it’s been saved. I can only presume this must be normal behavior for the Windows version, then. (?)

Installing a new version doesn’t make a difference. Try to start LO in Safe Mode:
Help → Restart in Safe Mode… → Restart → Proceed Safe Mode
This will start your LibreOffice installation with a clear user profile. Then try it again in this mode.

Have tested it now also with embedded Firebird. I could create a table, could save the created table, could edit the fields, the description for a field from a table I reopened …

Seems we need somebody using windows to test this.

1 Like

Seems we need somebody using windows to test this.

Creating new fields and saving them, then editing them again works fine for me.

Base Tabelle Felder hinzufügen

However, I have now made no further changes regarding field type or description.

With me:
Version: (x64) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

@twodawgs :

Use the tip from @RobertG


The buggy behavior seems to appear by changing old existing fields (like field “annotation” to “anno”) and adding a description to an existing field.

by changing old existing fields (like field “annotation” to “anno”) and adding a description to an existing field.

It makes no difference.

Base Tabelle Felder hinzufügen2

Hello @twodawgs ,

From the main Base screen, the bottom line is the status bar. What is displayed in the lower left corner?


My thought here is that this is not an embedded but rather a split DB - that is what the description leads to.

Unfortunately, checking with a split DB using LO v7.2.0.4 on Ubuntu 20.04 there is a major issue. The directories get all screwed up with the database and jar directories getting much dropped. My guess here is it may have something to do with “ScriptForge”.

Edit 2:

Title is missing from Base main screen.

Can alternatively get title using:

Rem Get Document location
sPathURL = ThisDatabaseDocument.URL
sName = FileNameoutofPath(sPathURL)

@RobertG, tried your directions to try Safe Mode, and the table design view still does not allow me to edit the properties of existing fields. Thanks for the suggestion.


What is on the lower left corner of status bar on main Base screen?

Here’s a screen shot of my main screen. I considered using a split DB, but I’m too lazy to go through the steps of setting it up for that.

As for the missing title, can you explain a little more what you’re referring to?

Thank you for the response. Shoots down my thought. Your description of table editing is like a split db. Have not experienced this in an embedded DB.

Haven’t checked under Windows but on Linux the file name is missing from the title bar. This is used in at least one macro dealing with split databases and I use it in a portable version with Firebird external.

You haven’t added any HSQLDB .jar files to the Base Class Path have your?

@Hrbrgr, thanks for the demo. As long as I know that’s what it’s supposed to do, I’ll keep trying…

Also, can you post a copy of that Base file (I imagine there is no data in there yet)?

Right, it’s just for testing, but it does replicate the issue on my computer.
test-02.odb (2.2 KB)

I also noticed a sub-folder with the same name that was created, that contains two more files:
test-02.properties and test-02.script. Do you need those, as well?

There is no table in the file you attached…

I also noticed a sub-folder with the same name that was created, that contains two more files:
test-02.properties and test-02.script. Do you need those, as well?

Split file gone bad.


Your last comment and the sample provided indicate a split database. Those extra files are supposed to be in the Base file when using embedded. The Base file you posted had no table in it. I imagine it is in the other files you have.

Try the attached. Download and place in a different directory and see it you can edit my simply table. If not, will need to look at something else on your system.

test-02.odb (3.5 KB)

I saved your odb file in a different directory and opened it. Here are the results:

  • When I opened your test-02.odb, Base created a subfolder with the same name and generated files with the same file name specs as I mentioned previously.

  • I opened the table in Design View, and still was not able to edit previously saved field info.

So we’ve gotten a little farther with figuring this out - and I’m very grateful for your help with this, I would have had no clue otherwise. The question now is, when I’m creating a new database and choose “Embedded database” as the database platform and “Embedded HsqlDB Driver” for the database driver, why would Base create a split database?

One thing that may be a factor is, when I had v 7.1.x of LibreOffice, I upgraded the HsqlDB driver to a more recent version, just because 7.2.x still had not come out by then and I just wanted a more recent version. However, I did not do this with the intent of using split databases, and did none of the steps involved in configuring Base for split databases (that I’m aware of). Still, could that have fouled up something? And would that still affect my current installation of it, now that I have a clean install of v 7.2.x? I made sure the driver I installed was deleted, and the current install now uses whatever comes “out of the box”.


Note that there is no HSQLDB driver to update with LO. The embedded database provided is a very old version (v1.8) and using a different version requires using a different process.

It sounds as if you have some macro installed and this is creating the additional sub directories and files. Also would be interested in knowing just what you did in “upgrading the HsqlDDB driver”.

For another test, rename your user profile → LibreOffice user profile and then try to create another HSQLDB embedded Base file as you just did.

To answer your question about the upgrade I did, I followed directions I found at http://hsqldb.org/web/openoffice.html. (I know it refers to OO in the URL, but it was also stated that this content applies to LO as well.) It basically involved installing a new extension and replacing the hsqldb.jar file with one from a newer version of hsqldb. When I did this, I could verify I had a newer version by viewing the Options for the HsqlDBembeddedOOo extension. Before following this procedure, the HsqlDB driver version shown was 1.8. Afterwards, the version shown was 2.5.

Some of the instructions lacked some detail, so it’s entirely possible I screwed something up. I would think uninstalling everything and reinstalling LO would have undone anything I did with the previous installation, but who knows what gets left behind when you uninstall a software app.

I will do your user profile test tomorrow and let you know the result.


Now it appears this is the source of the problem. You installed an extension which creates this split file. Reloading LO or installing a new version will not change this. Resetting the user profile should fix it but probably is not necessary.

From any LO menu, select Tools->Extension Manager...

Then in the dialog, click on the extension you installed and then click on the Remove button. Close the dialog and try creating a new Base embedded file. Should work without the extra directories created.