Unable to enter mac address: changed to time format

LibreOffice Ubuntu 16.04 Calc

I’m trying to populate a column with mac addresses 00:10:00:10:00:10

after typing 00:10, the entry becomes time format.
I’ve been unable to prevent this from happening, any format option I try gives the same result.
What am I missing?


Found it.
Tools → AutoCorrect Options → Options → uncheck “Use replacement table”

The replacement table shows lots of char combinations to replace with extended stuff.
I was typing chars which were replaced with time icons.

Right click on the column heading ( ie: A, B, C, etc) of the column you want to change then select Format from the popup menu. Select the Numbers tab then select Number in the ‘Category’. In Format Code line (lower left), enter 00:00:00:00:00:00. Click OK.

PS: you don’t need to type the : - just the numbers - 0001 entry = 00:00:00:00:00:01.

Ah, if I don’t type the “:”, I don’t get the auto time format (inserted clock icon)

However, a couple issues:

leading zeros are removed, they are required for MAC addresses, the contents of the cell show in the box above as entered, without “:”, the formatting doesn’t work if the MAC address includes characters (it is a hex number: a1:b2:c3:d4:e5:f6 is legal.

I am looking for a way to enter the data as text, but no success disabling the conversion to time if the address starts with 10:10 …

You’re absolutely right, I overlooked MAC.

I believe you may have to enter the complete 12 digits as text & convert it like:



OK, I’ll pursue that (time to learn some calc programming)

So there is no way to simply turn off the automatic conversion and enter as raw text? Does that surprise anyone else?


Certainly. Just change the format of the cell to Text. You’ll just have to enter the full number & colons.

In a ‘text’ column, upon typing 00:10 it is automatically converted to ‘time’, replaced by the clock icon. I want to turn this conversion off, have not been able to.

If the MAC is 00:10:00:10:00:10, it displays as 3 clock icons.

Never seen icon replacing entered data. Have you added any extensions? I’ve used LO v5.1.2 & v5.1.3 & it’s not in the installed version to my knowledge. Also found nothing on a search. Does this happen when starting a new calc doc?

Build ID: 1:5.1.2-0ubuntu1

I type ‘libreoffice’ at the command line, select ‘Calc Spreadsheet’ enter into cell ‘00:10:’ and the clock icon appears, same result if column is first given ‘text’ format (format code = ‘@’)

Tools → Extension manager shows a blank window …

The forum won’t allow me to provide a screenshot …

There are two other options. Reset the user profile. For instructions click on this link. The other, completely wipe out LO & download a new copy from the LibreOffice site - not through Ubuntu. These commands will remove all the LibreOffice and LibreOffice asociated files from your system.

$ sudo apt-get remove --purge libreoffice*
$ sudo apt-get clean
$ sudo apt-get autoremove