Unable to install language tool in LO 4.4 under Ubuntu

Whenever I try to install language tool 2.8 on my Libre Office v.4.4 running on Ubuntu I always get the same error which prevents me from installing it:

(com.sun.star.uno.RuntimeException) { { Message = “unknown error!”, Context = (com.sun.star.uno.XInterface) @0 } }

Apparently the latest version (2.8) should be compatible with LO 4.4 and in fact I successfully installed it under Windows. After having checked my system settings (see below) I found this message on Language Tool’s forum which states that it may be related to Libreoffice instead of being Language Tool’s problem.

My system settings are the following ones:

  • Libreoffice 4.4
  • Kubuntu 14.04
  • Java version: java version “1.7.0_76”, Java™ SE Runtime Environment (build 1.7.0_76-b13), Java HotSpot™ 64-Bit Server VM (build 24.76-b04, mixed mode)

After some more research I found out that the problem can be solved by installing the package libreoffice-java-common from repositories

which version of libreoffice-java-common did you install? This is not working for me on Ubuntu 14.04 with LO 4.4 and the latest libreoffice-java-common from repositories [libreoffice-java-common (1:4.4.0~rc3-0ubuntu1~trusty1)]

solved by uninstalling libreoffice (apt remove libreoffice-*) and then installing the latest version from the repositories. funnily I think this is the same version I had (4.4.0), but now it is working.