Unable to modify/delete a marked Index Entry

.ODT documents

I am new to Index management; mostly OK so far. However:

  • I can select shaded text for Index entries.

  • Can successfully see the resultant Index generated.

  • Can do manual editing, if needed, but…

I goof-up on the first-time key assignment of a shaded string [call it ‘Cats’]. So it gets built in the wrong place in the Index. I need to re-assign that shaded string to the key ‘Dogs’.

On this site I read, “Look for the ones [shaded index entry fields] you’re interested in, right-click and ‘Index Entry’ to open the editing dialog; you have a ‘Delete’ button there.”

– – –

I’ll take a shot at [first-time post] including/uploading images of what I get by way of any ‘editing dialog’, upon a right-click within shaded string:

<Image: 1. Index Entry - Right Click on shading offers Index Entry>

which yields …

<Image: 2. 2. Index Entry - cannot Modify or Delete>

Same result via Edit > Reference > Index Entry.

That is to say, I don’t see no Delete, no Edit, no Modify, no Reset. In short, I CANNOT remove an entry, in order to correctly re-declare it.`

Seems NOT to have to do with 'Enable cursor / Protected areas.

I would be way bunches appreciative of timely guidance.

– – –

Libre Version:


Share a sample document containing the typical problem (upload here on the ask site or provide a download link). Screenshot only cannot entirely explain the task.

Thank you, Grantler. Excellent suggestion. Knowing now this option, shall in future employ.

Bingo, ajlittoz –

The key is simply, “Use the OK button”.

Funny thing is, I realized I had duplicate entries. But mistakenly believed I was to somehow execute the ‘Delete’, right there in the first dialog box that showed.

The value of your promptness cannot be overstated.

Thank you.

This specific dialog pops up when you have two identical index entries on the same sequence of your text.

Select one of them and OK. You’ll then get the edit dialog where you can remove the selected entry.