Unable to open database after a restore

Have used Base with a lot of success for about a year. Ran into a problem with other parts of OS and had to recover with DJ Backup.

Everything looks good on the first two screen. “Open a recent database file” sees the database file. tapping finish brings up the first screen Database and Tasks/Forms . Also the Database column has Forms highlighted and Forms shows the forms that were created - the list of forms is accurate.

But, if I try to do anything - like click on Tables get the following message or other items.
The connection to the data source “CUSJ-Database” could not be established.

Running : Ubuntu 19.4, mem. 7.7 Gib, intel core I3, Gnome 3.32.1,OS type 64-bit, disk SSC 240 GB

Thanks Gary
Thanks Gary


You have not specified what type of database (and if other than embedded DB the connection type) you are using or the specific LO version being used.

Depending upon that, you may want to check the database connection settings → Edit->Database both Properties and Connection Type. Also check, especially if not using an embedded DB, the settings in Tools->Options under LibreOffice->Advanced for Java and connectors.

I am using an embedded LO DB - no server.
“…connection settings → Edit->Database” both ‘properties’ and ‘connections’ are greyed out. “Advanced Settings” are all ticked off.
“…in Tools->Options under LibreOffice->Advanced for Java and connectors.” Oracle Corporation 1.8.0_211, location /usr/lib/jvm/jre1.8.0_211.
LibreOffice Base >Connections Connection pooling enabled
com.sun.star.comp.sdbc.ODBCDriver yes 60
~ sdbc.JDBCDriver yes 60
~ sdbc.dbase.ODriver yes 60
~ sdbc.firebird.ODriver yes 120
The above, I have clicked on Apply OK then left the screen. On returning to the screen, ODBCDriver is always selected.
LibreOffice Base > Databases shows Registered Database
Bibliography ~/4/usr/database/biblio.odb is highlighted even when I have selected:
CUSJ-Database /home/gary/Documents/Unitarian/CUSJ/Database-project/CUSJ-Database.odb

Still don’t know what DB you are using. Embedded can be either Firebird or HSQLDB - displayed at bottom center of Base screen.

In Tools->Options:

  • Under LibreOfice->Advanced, Use a Java runtime environment should be have checkmark in box. Also Oracle (JRE) should be selected (dot in circle to left of “Oracle”)

  • Under LibreOffice Base->Connections remove the checkmark in Connection pooling enabled.

  • Save then close ALL open LO programs running. Then restart Base & test.

If still a problem will need a sample .odb Base file without personal/confidential information.

Still a problem

Embedded is HSQLDB
. Use a Java runtime environment is checkmarked in box and Oracle (JRE) is selected (dot in circle to left of “Oracle”)
• Under LibreOffice Base->Connections removed the checkmark in Connection pooling enabled.
Did save All then closed ALL open LO programs running. Then restarted Base & test.
Had the same result
How do I send you the database file without the table contents? The database has member Name and Address information as well as small donations and other related data for a social justice organization. Base /home/gary/Documents/Unitarian/CUSJ/Database-project/CUSJ-database/CUSJ-Database.odb 133,175 kb
Thanks for your help

Tried to created a database with HSQLDB, error appeared when I tried to create a table.
Then created a database with Firebird Embedded. Was able to set up a table with three records. Saved and closed the database. Was able to restart the test database and open the table. Does that mean the problematic CUSJ-Databse should be a Firebird Embedded instead of a HSQLDB embedded? How do I change that?

A guess here is that you have a problem with the Java installation. Firebird ran and does not need Java. HSQLDB does need Java. You can run Firebird without Java but you lose other functions such as Wizards and Report Builder.

You can try re-installing Oracle JRE or use OpenJDK (have used both on Ubuntu 18.04). You can have multiple versions installed simultaneously. Remember that 64-bit LO needs 64-bit Java. Also, verify then that this is selected in Advanced options of Options.

Sure you are right but has not worked with me.
In tools>option>Libreoffice>Advanced have tried with
Oracle Corporation 1.8.0_211 Location: /usr/lib/jvm/jre1.8.0_211

Ubuntu 11.0.3 Location :/usr/lib/jvm/java-11-openjdk-amd64
Also added Location :/usr/lib/jvm/java-1.11-openjdk-amd64
but it shows up as Location :/usr/lib/jvm/java-11-openjdk-amd64 in >Advanced

Oracle Corporation 1.8.0_211 Location: /usr/lib/jvm/jre1.8.0_211
was extracted from /usr/lib/jvm/jre-8u211-linux-x64-.tar.gz
Tried and retried but none of them work for me

removed and re-installed Base with sudo before some of the trials
Tried with Firebird but it finds my table names too long, so got nowhere with that.

Only thing I have left - try to reset user profile (not done during re-installation). See → LibreOffice user profile.

If still a problem may want to file a bug report → Bugzilla.

Hi Ratslinger,
I will follow your suggestion later today - too much to do today. And first need to take a large backup.
Thanks Gary

Seems like Ubuntu 19.04 broke Base.
Solution: Installed Ubuntu 18.04.2 LTS, installed Base with sudo apt-get install libreoffice-base

Likely some part of JAVA actually broken on 19.04 so HSQLDB database could not be opened.

Thank you for helping me.