Unable to open files from windows share

Build ID: 350m1(Build:2)
Debian Wheezy/3.2.0-4-686-pae

I am unable to open files from a Windows Share using LibreOffice (tried both write, calc). I can open other files from the Windows Share when I am not using LibreOffice (eg. using gedit).

I am having to create a local copy to be able to read files from the Windows Share, which is quite inconvinient.

Any help on this would be greatly appreciated.

Thanks in advance.

@teambob: Thanks, installing libreoffice-gnome fixed the issue :slight_smile: I don’t have “minimum reputation of 250” so i can’t close this question. Would the mods be kind enough to do so for me?

@Vicky1 I believe by accepting my answer you have effectively closed the answer. It will remain available for other people to read and add any extra information later.

I had a similar problem on Ubuntu. Make sure the Libreoffice Gnome integration package is installed. In my case the package was libreoffice-gnome

I install it but for sorry it is the same. I am running libreoffice 5

Hi @Anonymous2,

Here are some repro steps I just took to try to test out the problem you’re experiencing:

Create the document:

  • Open up LibreOffice Writer (I’m using on Ubuntu 12.04.1)
  • Create a new ODT document and save it to a Windows share (I’m running SAMBA 3.6.3 on Ubuntu 12.04.1)
  • Close LO Writer

Open the document:

  • Open LO Writer again
  • Navigate to the directory on the Windows share and open the document

Save the document (to confirm read/write capability):

  • (With the document open) add a new line of text
  • Save the document back to the Windows share

I’m able to perform these tasks successfully with my setup – could you please try to duplicate them as closely as possible on your machine so that we can track down your issue?



I can’t figure out how to navigate to the windows share from LibreOffice. I do have it as a bookmark in “Places”, and can access it fine from there.

I tried to mount the windows share by following the instructions here: http://forums.debian.net/viewtopic.php?f=5&t=73353
I ended up with the following error:
mount error(115): Operation now in progress
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
which looks like a bug in Debian testing as per this link: http://superuser.com/questions/374868/cannot-mount-windows-share-anymore-from-debian-linux (although my version of cifs-tools is different)

The funny thing is I have another computer with the exact same software setup as this one and I can open files from Windows Shares by simply double clicking on that computer.

Thanks for your replies. I tried them all and nothing works. I have tested this on Linux Mint 14 32 and 64 bit MATE - CINNAMON as well as Ubuntu 12.04 and 12.10. Seems to work fine in Linux Mint 32 and 64 bit KDE versions. Any ideas? This used to work in earlier versions of Ubuntu flavors (Linux Mint 11,12 Zorin 5, Ubuntu 10, 11). I did have to modify the fstab file with nobr1 but this no longer works.

The fstab option is “nobrl” (ending in lowercase L) rather than “nobr1” as you indicate.

I have the same issue, or so it seems; Libreoffice Gnome integration is installed integration is installed however. But I’m running on Linux Mint Mate … some compatibility issue between Mate and Gnome still ?

I did get it to work using the libreoffice dialogs instead of the gnome-dialogs.
(Menu) Tools → Options
Under top tree (Libreoffice, select General, and check “Use Libreoffice Dialogs”


I have Ubuntu 13.04 with LO 4.1.1 and yes the gnome integration is installed. I did try the Use LibreOffice Dialogs suggestion above and it did not work or me. Still searching for solutions…