Unable to save embedded EPS image

So I have a ODG file with an embedded EPS vector image, which I’d like to have as an independent file. These are the things I’ve tried so far to extract it without success:

  1. Right-click the image and use “Save the image…”. Nothing happens: no error message, no save dialog, nothing (same behavior in up-to-date OS X 10.12.2 (LO, Linuxmint 17.2 and Windows 10 x64 (LO
  2. Copy image and paste in Impress, Writer. I can paste, but have the same behavior reported on previous step.
  3. Print to normal printer, to PDF printer or Export as PDF. Instead of printing the image, a blank rectangle with the image’s technical data appears.
  4. Copy and paste in Adobe Illustrator, Adobe Photoshop, Inkscape (hadn’t many expectations). The image rasterizes on paste, which is inconvenient.
  5. Copy image in Draw, paste in Writer, export document as HTML. The embedded image is transformed to an IMG tag with data uri. Transformed this base 64 encoded data back to a file (some programming involved) and the result turned out to be a SVM file (StarView MetaFile, version 256) which if I open, takes me back to square 1: an ODG file with an embedded EPS.
  6. Tried some online converters and the result file is always rasterized :frowning:

I feel out of luck, stuck with an EPS I can’t alter. Anyone help care to help?
The file is at http://bit.ly/2jBSl9W, if anyone wants to give it a try.


The ODF files are ZIP archives. So, just rename the ODG to ZIP, open with a ZIP manager, and extract the EPS from Pictures subfolder.